View Full Version : Failed to Initialize Renderer LOG


adams_antics
Oct 27, 2005, 01:05 AM
ok.. since my job is to do tech support (for a different company, NOT firaxis), i know how these things work.. we could be waiting FOREVER for a fix for this.

so here's my idea.. WE find a solution... i tried the windows updates, driver revert, reupdate, etc. no resolution (i have an AMD Athlon XP 2600+, Radeon 9600 128mb, XP sp2, etc)

so i started poking around in my civ game settings... the app folder didn't have much, so i went to...

C:\Documents and Settings\Adam\My Documents\My Games\Sid Meier's Civilization 4\

edited the CivilizationIV.ini file, changed around a few values, couldn't fix the problem, so i turned on the logging...

LoggingEnabled = 1
MessageLog = 1

then i ran it again and checked out the log folder, i found this in the init.log file:

[667.296] ERR: Initialize Renderer failed - parameters:
- width = 1024
- height = 768
- flags = 0x8
- hwnd = 0x490108
- adaptrid = 0
- deviceid = 1
[667.296] DBG: Failed to Initialize Renderer - Check DirectX Version

i noticed changing other values (like fullscreen=ask) did affect the startup, but when i changed the screen height/width, it did not. but it's the adaptrid that has me concerned.

so then.. i installed it on my old computer, it was having the other problem mentioned about the black map, but the game starts, so i checked the log on it. i scoured through the logs but could not find any helpful information, it went right past that ERR part without the details... i did notice on the PythonDbg.log, the comp that errors has the last line "load_module CvTranslator", and the old one continues on "8 SCREEN TURNED ON".. then keeps going.

i'm done for the night.

j/w though.. for anyone that has called tech support.. do they even turn on these logs or try changing any game settings at all?