Advertisement
Civilization Fanatics' Center  

Go Back   Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Technical Support

Reply
 
Thread Tools
Old Jul 10, 2010, 10:29 AM   #1
GB123
Chieftain
 
Join Date: Jul 2010
Posts: 1
Init Engine Error (Invalid 3D device type)

Purchased CIV 4 (Game of the Year edition) and I am having problems with the install/startup of the game. I am running Windows 7 (32 bit) edition. The post below are the details of the system and the error message (appears related to DirectX)

DirectX diagnostic Tool:
System Information:
Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7600)
System Manufacture: HP Pavilion 061
System Model: DN124A-ABA 869C
BIOS: BIOS Date: 06/27/03 20:48:32 Ver: 08.00.08
Processor: Intel(R) Pentium(R) 4 CPU 3.00 GHz (2 CPUs), ~3.0GHz
Memory: 2048MB RAM
Page file: 996MB used, 3098MB available
DirectX Version: DirectX 11

Display
Device
Name: Standard VGA Graphics Adapter
Manufacture: (Standard display types)
Chip Type: NVIDIA
DAC Type: 8 bit
Approx. Total Memory: n/a
Current Display Mode: 1280 x 1024 (32 bit) (1Hz)
Monitor: GenericPnP Monitor

... All DirectX features show "Not Available"

The error occurs
at the last stage of the InitEngine with the followling:

Initialize Renderer failed. Check DirectX Installation, Latest Graphics
Drivers and Graphics Settings
Parameters
- width = 1024
- height = 768
- flags = 0xc
- hwnd = 0x470664
- adaptrid = 0
-deviceid = 3
Error:Creation failed: Invalid 3D device type

I have checked serveral threads in this and a few other forums but nothing indicates that it works (or doesn't) in Windows 7.

BTW - This is a new install on this machine. Used to run CIV II but de-installed it
prior to atempting to install CIV 4.

Any assistance would be greately appreciated.

Gerry
GB123 is offline   Reply With Quote
Old Jul 10, 2010, 02:50 PM   #2
Furiey
No Longer Just Lurking
 
Furiey's Avatar
 
Join Date: Nov 2003
Location: Bedfordshire UK
Posts: 6,340
Welcome to CFC!

It does work on W7.

Install the most recent version of DirectX 9c from Microsoft

Make sure you have the latest patches installed, Warlords should be 2.13 and Beyond the Sword 3.19 (I'm not sure from memory what expansions game of the year includes). You can download these if you need them from the downloads section of this site.

Make sure you run any patches by rightclicking on the .exe and selecting run as administrator.
Furiey is offline   Reply With Quote
Old Aug 18, 2011, 07:29 AM   #3
nordicwolf
Chieftain
 
Join Date: Aug 2011
Posts: 1
Same problem

I have the same problem. Same error. I followed this to the letter, http://forums.civfanatics.com/showthread.php?t=408537 even using the original disks and a digital download from amazon. Still get the same "3D" error.

I read on other Forum posts that it runs on Windows 7, but I have no idea how.

Furiey, can you help?
nordicwolf is offline   Reply With Quote
Reply

Bookmarks

Go Back Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Technical Support > Init Engine Error (Invalid 3D device type)

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BTS] INIT ENGINE Hang wilkie Civ4 - Technical Support 2 Apr 27, 2010 08:27 PM
Invalid 3D Device Type AntiTwelve Civ4 - Technical Support 11 Apr 11, 2009 07:34 AM
Init Engine Faliure settler114 Civ4 - Bug Reports 4 Nov 11, 2007 03:39 PM
invalid 3D device type Grubdubdub Civ4 - Technical Support 2 Nov 05, 2007 10:59 PM
BtS : invalid voice device problem kernok Civ4 - Technical Support 2 Oct 08, 2007 10:18 AM


Advertisement

All times are GMT -6. The time now is 10:29 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This site is copyright Civilization Fanatics' Center.
Support CFC: Amazon.com | Amazon UK | Amazon DE | Amazon CA | Amazon FR