Advertisement
Civilization Fanatics' Center  

Go Back   Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Colonization > Civ4Col - Technical Support

Reply
 
Thread Tools
Old Mar 31, 2011, 03:57 PM   #1
angelofbaal
Chieftain
 
Join Date: Mar 2011
Posts: 1
Game kind of loads but runs crazy...help!

Hi,

Loved the original, hoping to love this version...think Windows 7 is being a pain.

I downloaded a legal copy (from GAME) and installed, then installed a patch (no installer needed patch? I think) The Firaxis patch said I didn't have col installed when I clearly did,

Anyway this [patch allowed the game to open, title sequence to play etc, I can choose my country and leader. However when I het to the actual game screen, I can see no land or ocean, the sound is repeating itself, the turn numbers, dates and messages are running really fast at the top of the screen and I cant do anything or even quit the program.

Somebody please help.

Thanks
angelofbaal is offline   Reply With Quote
Reply

Bookmarks

Go Back Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Colonization > Civ4Col - Technical Support > Game kind of loads but runs crazy...help!

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Advertisement

All times are GMT -6. The time now is 01:15 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This site is copyright Civilization Fanatics' Center.
Support CFC: Amazon.com | Amazon UK | Amazon DE | Amazon CA | Amazon FR