1. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  2. Main site is finally re-opened! We migrated it to a new CMS and gave it a new layout as well.
    Dismiss Notice
  3. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice
  4. Downloads database has been migrated and re-opened! Check it out and post in Site Feedback if any issue. We have done URL re-write so that old links will continue to work.
    Dismiss Notice
  5. A new Civ6 theme forum style is now available and it's made the default forum style! Check it out and comment here.
    Dismiss Notice
  6. We have successfully migrated the forum from vBulletin to Xenforo! Please take a look around and report any issue you see in Site Feedback.
    Dismiss Notice

Performance revelations: changing graphics cards

Discussion in 'Civ4 - Technical Support' started by Divide Overflow, Nov 8, 2005.

  1. Divide Overflow

    Divide Overflow Chieftain

    Oct 31, 2005
    I first installed CivIV onto my system with a brand new 6600GT video card in place. I was able to start and complete several standard games at high graphics settings with only moderately irritating stuttering in all Wonder movies, the occasional in-game sound effects and lagging before entering discussions with a foreign ruler. (1024x768, 2x filtering) To be honest, I wondered why many of you were making such a fuss, things seemed to be working ok for me. Unfortunately, my video card proved to be defective and had to be returned, forcing me to fall back to an older GF4 Ti 4400. The gameplay changed drastically once I downgraded the video card, but left all other system components unchanged.

    Despite changing my graphics settings to medium or even low, the game now lags at a snail’s pace, with frequent lockups and long periods of unresponsive behavior. This happens despite what is being displayed on the screen. Even the passive time between turns takes considerably longer with the weaker video card in my system. This just doesn’t make sense to me, and it’s unlike any game experience I’ve had before. My GF4 will happily play almost all modern games as long as the graphics quality are set to medium to low. CivIV seems to be different. (Yes, the drivers were uninstalled and rolled back to a version more suitable to the older hardware.)

    I now understand the complaints of so many others out there who have much weaker video cards than my GF4, but still above the minimum requirements or even recommended system specifications. Firaxis has some serious patching to do and/or should make some serious changes to the minimum hardware requirements.

    They never should have released the game in this condition.

Share This Page