1. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  2. Main site is finally re-opened! We migrated it to a new CMS and gave it a new layout as well.
    Dismiss Notice
  3. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice
  4. Downloads database has been migrated and re-opened! Check it out and post in Site Feedback if any issue. We have done URL re-write so that old links will continue to work.
    Dismiss Notice
  5. A new Civ6 theme forum style is now available and it's made the default forum style! Check it out and comment here.
    Dismiss Notice
  6. We have successfully migrated the forum from vBulletin to Xenforo! Please take a look around and report any issue you see in Site Feedback.
    Dismiss Notice

Windows 7 Fix that worked for me.

Discussion in 'Civ3 - Technical Support' started by Civ_43, Apr 23, 2012.

  1. Civ_43

    Civ_43 Chieftain

    Oct 3, 2007
    I recently re-installed Civ 3 Golden Edition and got he appcrash error. I installed it with run in windows compatibility mode and run as administrator. I found out that if I turned off my avg Anti-virus it worked. Then I tried it with it on after first tried it without and It worked as well. So maybe some could try this:

    1. Install it just as it says in the sticky thread up top.

    2. After installing it and getting the up to date patches, just turn off your Anti-Virus only if you can Then try it.

    If you would rather have your anti-virus on then try it first off.

    3. Then turn you Anti-Virus on and try it.

    I just thought I would post this just to see if it would work for anyone. I only have the Golden Edition so no guarantee it would work with civ 3 complete edition.

Share This Page