1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

[R&F] [1.0.0.216] DLC load order is messed up when some mods are activated and R&F ruleset is used

Discussion in 'Civ6 - Bug Reports' started by Gedemon, Feb 9, 2018.

  1. Gedemon

    Gedemon Modder Moderator

    Joined:
    Oct 4, 2004
    Messages:
    7,453
    Location:
    France
    I don't have R&F, this report is based on the logs and tests from users helping me to fix YnAMP for R&F:

    When some mods (not all) are enabled, and when using the R&F ruleset (vanilla game seems to be not affected), some (ie "random") DLC try to load their R&F compatibility file (like CivilizationName_Expansion1.xml) before the base data for the DLC is loaded, resulting in a DB lock because of missing references (and sending the user back to main menu)

    See here for the workaround (and some example of logs in the previous and following posts):
    https://forums.civfanatics.com/thre...s-pack-for-civ6.602050/page-113#post-15030549

    edit for workaround link: https://forums.civfanatics.com/reso...ng-to-main-menu-with-r-f-and-some-mods.26701/
     
    Last edited: Feb 10, 2018

Share This Page