[GS] [1.0.0.317] Netherland's new bonus is not working.

Discussion in 'Civ6 - Bug Reports' started by cholsy, Apr 12, 2019.

  1. cholsy

    cholsy Warlord

    Joined:
    Dec 20, 2010
    Messages:
    180
    +50% towards Flood Barrier, not working.

    City Cost Progress Remaining Production Turn left This should be
    ---------------------------------------------------------------------------------------------------------
    Amsterdam 1200 835 365 65.1 6 4
    Mainz 720 452 268 30.4 9 6
    Groningen 240 82 158 41 4 3

    Dam district not tested.
    Save file attached.
     

    Attached Files:

  2. dshirk

    dshirk Firaxian

    Joined:
    Oct 31, 2005
    Messages:
    879
    Taking a look. Thank you for the save!
     
  3. cholsy

    cholsy Warlord

    Joined:
    Dec 20, 2010
    Messages:
    180
    @firaxis,
    Just reminder.
    This bug is still alive today, [1.0.0.341].
    I attached new simple save file to reproduce.
    City production is 14.7. On next turn, production for flood barrier should have been 21 but 14.

    I have checked Dam district. It works.
     

    Attached Files:

  4. cvb

    cvb Prince

    Joined:
    Jun 12, 2017
    Messages:
    446
    Maybe @firaxis isn't doing, what you are trying to achieve. firaxis was last seen: 31 Jul 2008

    FXS_Sarah was last seen: 4 Dec 2019
    dshirk was last seen: 5 Dec 2019
    FXS_MisterKevin was last seen: Friday at 16:00

    .
     
  5. Laurana Kanan

    Laurana Kanan Don’t underestimate who I am. Moderator

    Joined:
    Apr 10, 2014
    Messages:
    3,568
    Gender:
    Female
    Location:
    Near the Greatest Snow on Earth
    @dshirk - Just double-checked this, and yes it's still not working in version 1.0.1.501. However, it's a simple mistake in the ModifierArguments where Name is set to DistrictType instead of BuildingType. Changing it allows the trait to properly function. Probably was just a copy+paste error from the Dam production bonus.
     
    pokiehl, FearSunn and Infixo like this.
  6. cholsy

    cholsy Warlord

    Joined:
    Dec 20, 2010
    Messages:
    180
    I tested this and found it works.

    Expansion1_Expansion2.XML
    <ModifierId>TRAIT_FLOOD_BARRIER_PRODUCTION</ModifierId>
    <Name>DistructType</Name>
    <Value>BUILDING_FLOOD_BARRIER</Value>

    I replaced DistrictType with BuildingType.
    Started new Dutch game. It seems to work.
     
  7. Laurana Kanan

    Laurana Kanan Don’t underestimate who I am. Moderator

    Joined:
    Apr 10, 2014
    Messages:
    3,568
    Gender:
    Female
    Location:
    Near the Greatest Snow on Earth
    It's a simple change, but FXS still did not fix in Ver. 1.0.2.39 June '20 update.
     
    Infixo likes this.
  8. cholsy

    cholsy Warlord

    Joined:
    Dec 20, 2010
    Messages:
    180
    You're right. They didn't.
    The update description says... "Additional general bug fixes and polish."
    I really wonder what their polish means, if they ignore something like this.
    I have not checked rest of my issues yet.
    However, I'm 90% sure that they didn't touch bugs I reported at all.
    I think they seldom review this bug report forum, just looking into only what they have interest in.
     
  9. Pfeffersack

    Pfeffersack Deity

    Joined:
    May 10, 2003
    Messages:
    3,058
    Location:
    Germany
    I have the impression that they monitor the bug forum and even download saves you provide, however fixing seems to take ist time then (and it probably subject to priorization). It also can't hurt to update old reports of bugs which get no fix in an update with a fresh example after the update (I imagine it might in increase chances of a later fix, because the devs can easier work with the bug in current version than in an older one)
     
  10. Laurana Kanan

    Laurana Kanan Don’t underestimate who I am. Moderator

    Joined:
    Apr 10, 2014
    Messages:
    3,568
    Gender:
    Female
    Location:
    Near the Greatest Snow on Earth
    From the October patch notes:
    • Fixed an issue where the Netherlands bonus of +50% towards Flood Barriers was not working.
     

Share This Page