1.52 - Wonder Movies still sluggish.

Discussion in 'Civ4 - Bug Reports' started by jdurg, Dec 24, 2005.

  1. jdurg

    jdurg Warlord

    Joined:
    Nov 7, 2001
    Messages:
    151
    Location:
    Connecticut
    In version 1.52, the first Wonder Movie that plays during the session plays absolutely flawlessly. Every other movie after that first one gets progressively worse until they no longer work at all. Seems as if something isn't getting cleared out and the movies no longer have room to work.
     
  2. cnahr

    cnahr Chieftain

    Joined:
    Dec 25, 2005
    Messages:
    4
    Same here, but I finally fixed the movie playback by restricting the CPU affinity of the Civ4 process to just one of my (virtual) CPUs.

    The following applies to systems that have a Pentium 4 with hyperthreading or possibly a multicore CPU. I'll quote my post on another forum:

    The various Bink performance setting in the ini file had no effect at all, other than making the videos uglier. That was to be expected since I'm running on a P4 @ 3.2 GHz with 2 GB RAM and a GeForce 6600 GT... it's not like that machine is somehow to slow to play back a video in a small window.

    What did have an effect was setting the CPU affinity of the Civ4 process (or rather the GameJackal process in which I'm running Civ4 to avoid the CD check) to just one of my two virtual CPUs. My Pentium 4 has hyperthreading, and Civ4 apparently has some serious race conditions in video playback on such a system, or at least on my system.

    After a long playtime the videos eventually still lock up altogether -- that's to say, I get a frozen frame while the sound keeps playing. But up to that point, at least, videos now play smoothly.

    I've also changed some ini options which seemed to improve playback slightly:

    Code:
    BinkNoSkip = 0 ; CHANGED, was 1
    DynamicAnimPaging = 0 ; CHANGED, was 1
    D3D9Query = 1 ; CHANGED, was 0
    You can set the CPU affinity of a process with the free Process Explorer utility by SysInternals. Unfortunately, it's not possible to set the CPU affinity for an executable, so Civ4 must be started before you can use PE. Another reason to use GameJackal because Civ4 inherits the affinity of the GJ process!

    Could anyone else who's having video playback trouble please try this out and let us know what happened? Also, post if you have an MT or dual-core CPU and you don't have these issues, or if you have a plain old single CPU and do have them. If it's really a hyperthreading issue Firaxis might finally be able to fix it in the next patch.
     
  3. cnahr

    cnahr Chieftain

    Joined:
    Dec 25, 2005
    Messages:
    4
    Er, I just found that deleting all files in the following folder and then restarting the game has the same effect:

    C:\Documents and Settings\<your name>\Application Data\My Games\Civilization\cache

    There was a post on Apolyton claiming that deleting these files would reset an internal anti-aliasing setting that caused movie stuttering. I don't know about that but this simple action seems to have the same effect on my system as the more convoluted CPU affinity setting I described above. Movies now play smoothly, up to a certain point where they lock up.
     
  4. aronk76

    aronk76 Chieftain

    Joined:
    Dec 24, 2005
    Messages:
    41
    Location:
    Virginia Beach, VA
    I am having a similar problem with all wonder movies. They play but they stutter. I will try clearing out the cache folder as listed above to see if that works.
     
  5. vbraun

    vbraun Raytracing

    Joined:
    Jul 7, 2003
    Messages:
    3,530
    Location:
    Arizona, USA
    Firaxis will eventually release Low-Res Wonder Movies. :)
     
  6. cnahr

    cnahr Chieftain

    Joined:
    Dec 25, 2005
    Messages:
    4
    Low-res movies might help some people with slow machines but I don't think they'll do anything for this issue.

    Our systems are far above minimum specs, and the existing movies already do play smoothly with the tricks I listed -- up to a point where they simply lock up.

    That's got to be some synchronization issue, or some incorrect use of the video driver, or both. Raw performance most likely isn't the issue here.
     
  7. aronk76

    aronk76 Chieftain

    Joined:
    Dec 24, 2005
    Messages:
    41
    Location:
    Virginia Beach, VA
    I also just tried clearing out the cache folder yesterday and it didn't help out at all. The wonder movies still stutter badly so I just click on OK to bypass them.
     
  8. Keith Larson

    Keith Larson A Wild Boar

    Joined:
    Feb 28, 2003
    Messages:
    241
    Location:
    Illinios
    My wonder movies played great before, now they always shutter.
     
  9. Korpulu

    Korpulu Chieftain

    Joined:
    Dec 22, 2005
    Messages:
    12
    Here is my problem/s.

    1: Leaderheads: Either a black screen, or a red screen, or a still leader on a red screen. Or the leader is fine, then one of the above happens. Or vice versa.( Good play, then one of the above, good play again.)..

    2: Wonder movies: The famous stutter on the first, then smooth play on the second. Many times a scrambled screen that is partly transparent. Or a combination of all three.

    Asus A7V8X w/ current BIOS. AMD 2700+ CPU. 2gig RAM, ATI 9800pro using 5.12.

    These are the only problems I've noticed. I don't have the other graphic problems others have posted about. Just the wonder/leader problems.

    So other than that, it's fine. Oh, this was a 1.09 problem too.
     
  10. Craterus22

    Craterus22 King

    Joined:
    Oct 7, 2001
    Messages:
    689
    Could they please just let us turn off movies completely???
     
  11. jdurg

    jdurg Warlord

    Joined:
    Nov 7, 2001
    Messages:
    151
    Location:
    Connecticut
    Yes, they do and they've allowed this since the initial version of the game. Go into your Civ4.ini file and change NoMovies = 0 to NoMovies = 1. Now the movies will no longer play.
     
  12. Craterus22

    Craterus22 King

    Joined:
    Oct 7, 2001
    Messages:
    689
    cool - thanks for the tip - its kind of a bummer that it isn't listed as a choice to check off in the low res options selection.
     
  13. microbe

    microbe Cascaded Mansion

    Joined:
    Nov 16, 2003
    Messages:
    4,596
    Yes. Movies used to be great but now terrible.
     
  14. Mumin

    Mumin Warlord

    Joined:
    Nov 18, 2005
    Messages:
    107
    Location:
    Sweden
    The movies stutter horribly for me too, BUT I can alt-tab out of the game and watch the movies in a separate program with no stuttering whatsoever. This makes me assume:

    The stuttering has precious little to do with performance and everything to do with crappy programming that doesn't release enough resorces to the movie. I'm strongly doubt releasing low-res movies will do ANYTHING to improve the stuttering.

    So Firaxis, just pause everything else and let the movie run unhindered. No zooming on the city or any other unnecessary effects. Black screen in the background. Just the movie. OK? ;)
     
  15. Craterus22

    Craterus22 King

    Joined:
    Oct 7, 2001
    Messages:
    689
  16. eric_

    eric_ Emperor

    Joined:
    Nov 29, 2005
    Messages:
    1,725
    Location:
    Riverdale, MD
    Why not just have it zoom in, then have the movie start...totally separate processes. I kinda like how it zooms in on the city with the flash of light. Totally unnecessary though. I won't cry if it gets nixed. I'd rather watch the movies if I have to choose.

    Glad to hear others who are above spec are running into WORSE problems with 1.52 than with 1.09 (which kind of improved upon the out-of-the-box situation.

    Anyone else experiencing a degredation of intro movie quality with 1.52? Not that it *really* matters, but it's annoying.
     
  17. Flak

    Flak vBülletin Förum

    Joined:
    May 10, 2001
    Messages:
    1,523
    Location:
    Manchester, England
    Well, I just upgraded to 1.52. And my movies are still stuttering. That's too bad. And now I finally have something that I did not have at anytime before: a graphics glitch. Very small, just the wierd skin thing on Cleopatra. Curiously, she seems to be the only one affected. Overrall an improvement in speed and memory management. I guess it was just not enough for me to get the movies playing though.

    I ran some tests running the movies while the game was on a huge map with 18 civs using the Rad bink movie player. All of the movies ran smoothely except the Pyramids, which does seem to have a larger frame. Even with the Pyramids, it was lot quicker, smoother, and the sound did not stutter at all, the video just blinked.

    I will be astounded if low-res movies fixes this. I actually am not even so sure this is a problem with the game itself. I think there might be an issue with the way these movies have been done.
     
  18. eric_

    eric_ Emperor

    Joined:
    Nov 29, 2005
    Messages:
    1,725
    Location:
    Riverdale, MD
    The only graphics glitch I've experienced so far (and it has been there from the start) is the exposure of flood plains tiles along a river in unexplored portions of the map...just the very light green part that outlines the river itself. It's ubiquitous through all games, all patches, and a v-card upgrade. I had some weird glitch on my old card and the 1.09 patch where certain portions of certain tiles turned black...that was only occassional and seems to have been resolved by the upgrade or 1.52.
     
  19. Frostyboy

    Frostyboy Never Beaten

    Joined:
    Nov 17, 2003
    Messages:
    1,046
    Location:
    Norway
    Before 1.52 (in 1.00), the wonder movies where more smoothly sluggish (it was mainly the sound), while now the picture jump more - even worse :(
     
  20. gunnergoz

    gunnergoz Cat Herder

    Joined:
    Jul 16, 2002
    Messages:
    2,307
    Gender:
    Male
    Location:
    Southern California
    I had the wonder movies working for a while there before 1.52 but then made some suggested adjustments to improve large and huge maps and then the game ran smoother but the movies ran choppy again. 1.52 has not improved the choppy movies but the game is more stable overall, for which I am happy. Still...what's with the in-game movies? The whole world wonders?
     

Share This Page