11 Second Turn Delay


King of the Beers
Jun 18, 2003
Hidden Underground Volcano Lair
Forgive me if this is in the wrong place. I dont exactly think this is a bug.

I am using a Dell M6500 laptop with 4GB of RAM to play the expansion and I am consistently getting an 11 second delay between turns. I’m wondering who else is experiencing this kind of slowness and is it something that is being addressed?

Should I start thinking about a new computer?

That kind of delay between turns really is not acceptable.:mad:
Moderator Action: Moved to tech support.

When do you get the performance problems? Already at the beginning? If so, then please check if it can be fixed with this suggestion.

When I first installed the expansion my game would 'work' on turn zero and then lock up on turn 1 when I tried to move my starting warrior.

Then, I went and did the suggestion above. I did that last week on the same day that i installed the expansion. This improved things slightly so that I can play things almost as normal in the beginning. But very soon after, I get the 11 second delay and the slight hesitation on unit moves.

Sometimes, if I cold reboot or exit Civ, and restart I can get some regular smoothness for about 1 to 5 turns tops. other times, I get the 11 second delay right from turn 0 after founding my city.

I described this to a guy at work and he said it almost sounded like a memory leak.

I am still at wotk now, but I will check the game core setting again tonight when I get home.
mmhh...a user reported, that he found some incredibly big savegames in his autosave folder, and that it got better after he deleted them.
Could you please check if this is here the same case?

Thank you for your attention in this matter. I will check that tonight. I know that I tried to turn off my auto saves by putting zeros in the options screen about turns between saves. I will check tat as well when I get home.
I think its better now. I did two things:

1.) Threw away all my saves, including autosaves except 1 G&K save I wanted to keep.

2.) Reset all my options to defaults.

I opened a new game and played a few turns with no issues. I am keeping my fingers crossed.

Thanks for the help.
Top Bottom