1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

2.81 No barbarians = No out of sync

Discussion in 'RoM Multiplayer' started by Snub, Dec 29, 2009.

  1. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Edit: Actually for most no barbarians is still out of sync. XD I don't know why it's working for us but not working for others.

    :hmm: Don't know if this is of any help to anyone, perhaps it's more of use to the developers:



    In RoM version 2.81 you can play multi-player against players and AI player
    without going OOS if you turn off barbarians. In the previous version (2.80) attacking
    another player, AI player or barbarian would cause an OOS.

    In a previous post I made for 2.80 (http://forums.civfanatics.com
    /showthread.php?t=342471
    ) you could play by overwriting the core
    dll with a previous version. Now you can just check "No barbarians" in the options
    before you host a game.

    It's a bit lame at first, (one scout can venture forth pretty much forever and settlers
    can expand fast so damn easily) but it's a way to play against your friends while still
    using the latest core dll. Actual resources! YAY :lol: :crazyeye: etc etc



    Happy newyear :p



    Get the latest version of RoM here http://forums.civfanatics.com/showthread.php?t=243164
     
  2. WildFire

    WildFire amour

    Joined:
    Sep 18, 2002
    Messages:
    5,186
    Location:
    mIRC
    In 2.8 it OOS'd when you attacked barbs or any other player (or at least for us it did)..

    You're saying you can attack the AI/other humans and it won't OOS?
     
  3. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Yes,

    I'm saying: For us, in 2.81 it doesn't OOS when attacking other AI or humans if you put barbs off in the options before hosting a game.
     
  4. DzimBo

    DzimBo Chieftain

    Joined:
    Dec 28, 2009
    Messages:
    15
    Location:
    Poland
    I disable it as barbaric, and so I continue to OOS in the attack on AI, I will add that I have rom version 2.81 + A New Dawn installed.
     
  5. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Mm, you didn't activate revolutions right? And- Are you really sure you are using 2.81? Did you overwrite all the files from the patch correctly?

    I have a clean install of civilization and RoM 2.81.

    Only thing I can think off that I have done different from a clean install is using unloaded modules (Civilization IV\Beyond the Sword\Mods\Rise of Mankind\Assets\Unloaded Modules). I've used static leader heads and no building graphs. Though I doubt that matters for the oos problem.

    And: I'm not using A New Dawn. Though I dont think that's the problem either- but I'll install to check it out. I'll post about it soonish.

    :crazyeye:
     
  6. DzimBo

    DzimBo Chieftain

    Joined:
    Dec 28, 2009
    Messages:
    15
    Location:
    Poland
    I mentioned just no barbarians, even on plain sparawdze RoM without any additives. A New Dawn v 1.351 installed on RoM 2.81 eliminates OOS is not only suited to this version of RoM, so mod it is not as it should.
     
  7. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    So here's my test for OOS in multiplayer while using A New Dawn.

    Download here: http://forums.civfanatics.com/downloads.php?do=file&id=12838


    ---

    First I installed A new dawn version 1.53 (with everything checked) I tested a multiplayer game WITHOUT patching to 1.54. This is what happened:

    When attacking another human player the game worked fine. However when attacking an AI player the game OOS.

    ---

    Then I installed the 1.54 patch for A new dawn.

    When attacking an AI player the game OOSed. I didn't try human player vs human player.

    --

    Then I reinstalled a clean version of RoM 2.81. Again it causes no OOS's in our LAN if you check "no barbarians" in the options.

    My conclusion:

    A new dawn is not compatible with the work around posted above. Playing with a new dawn (either version 1.53 or 1.54) causes OOS's in RoM 2.81 for the players in our LAN.
     
  8. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    ..I think my english is not good enough to understand this :p

    Look at my post above this one, maybe that will help.
     
  9. DzimBo

    DzimBo Chieftain

    Joined:
    Dec 28, 2009
    Messages:
    15
    Location:
    Poland
    So, I checked on a clean ROM 2.81 without installing a new dawn, turned off the barbarians, and so forth jumps OOS, and you play games on lan or direct IP connection? Injury with the addition of a new dawn crashes OOS, I do not clean RoM az is as good as with the addition of mods
     
  10. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Yes we play on a LAN. We don't have to use direct IP, it just shows up in the join game screen.

    I'm sorry it's not working for you, maybe anyone has an idea why it is working for some and not for others?
     
  11. DzimBo

    DzimBo Chieftain

    Joined:
    Dec 28, 2009
    Messages:
    15
    Location:
    Poland
    the point is that A New Dawn v 1.351 no OOS in multipalyer, but it is not 100% compatible with RoM 2.8 and 2.81.
     
  12. DzimBo

    DzimBo Chieftain

    Joined:
    Dec 28, 2009
    Messages:
    15
    Location:
    Poland
    Now I tested on lan games and also jumped OOS, in multiplayer, so I do not know why for me it does not work
     
  13. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Anyone else tried the work around? It can't be just our lan thats working right?
     
  14. WildFire

    WildFire amour

    Joined:
    Sep 18, 2002
    Messages:
    5,186
    Location:
    mIRC
    Will try it out on LAN
     
  15. WildFire

    WildFire amour

    Joined:
    Sep 18, 2002
    Messages:
    5,186
    Location:
    mIRC
    Out of sync with all settings you mentioned.

    LAN game, no barbs, no rev mod etc. OOS on attack of AI scout.
     
  16. Snub

    Snub Chieftain

    Joined:
    Oct 25, 2009
    Messages:
    26
    Location:
    Netherlands
    Thanks for testing.

    Really weird.. but it's not OOS'ing for us right now :confused: :confused:
     
  17. WildFire

    WildFire amour

    Joined:
    Sep 18, 2002
    Messages:
    5,186
    Location:
    mIRC
    Lucky SOB B)

    Enjoy it, hopefully with 2.9 the rest of us will be able to join you!
     

Share This Page