1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

2 major problems - freezing and no terrain

Discussion in 'Civ4 - Technical Support' started by WillSen, Oct 28, 2005.

  1. WillSen

    WillSen Chieftain

    Joined:
    Aug 13, 2004
    Messages:
    26
    I've installed the game - everything done correctly without problems. Then I start the game and it goes quite happily through the intro video and to the menu screen. I can then start a new game etc. with no problems. The game then proceeds to load with the progress bar progressing along. Then problems start. Sometimes it doesn't even finish the progress bar's progression before it completely freezes. Sometimes it does, but then freezes 2 secs into the actual game. Once I loaded it so fast that I actually got properly into the game, only to discover black terrain below the units and proper unaffected terrain to the side, where no units were.

    The game appears to be freezing about 2-5 mins in each time, which is normally as the progress bar is travelling across the screen. However the times I've actually reached the game, the terrain seemed to be completely dodgy, so even if I sort out the opening issues, there's still that problem.

    I'd be very grateful for any help with these seemingly impossible conundrums.

    Thank you in advance
     
  2. WillSen

    WillSen Chieftain

    Joined:
    Aug 13, 2004
    Messages:
    26
    no-one got any ideas of what the problem could be?
     
  3. TheBarnacle

    TheBarnacle Chieftain

    Joined:
    Oct 27, 2005
    Messages:
    92
    these seem to be similar to the problems everyone else is having re: video

    whether is card, driver, xml, rendering, dx issues...who knows. look around at other threads. i'm sure there are helpful tips you can try.
     
  4. cosinus

    cosinus Chieftain

    Joined:
    Oct 28, 2005
    Messages:
    3
    have the same proble. game often freezes when loading a game or starting a new one. after the progress bar runs through the game freezes when the status says "finished". and the sound loops endlessly (1 sec is looping forever).

    i'll try the fix for the video problems.

    cosinus
     

Share This Page