1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice

A New Dawn Beta Builds

Discussion in 'Rise of Mankind: A New Dawn' started by 45°38'N-13°47'E, Dec 3, 2009.

  1. zulu9812

    zulu9812 The Newbie Nightmare

    Joined:
    Jan 29, 2002
    Messages:
    6,388
    Location:
    Athens of the North
    I made new Mountaineering button art. It's in my modmod



    Uploaded with ImageShack.us
     
  2. zulu9812

    zulu9812 The Newbie Nightmare

    Joined:
    Jan 29, 2002
    Messages:
    6,388
    Location:
    Athens of the North
    The new installer doesn't work for me. It just hangs at the installing part, the progress bar doesn't move. The buttons (e.g. cancel) are also greyed out at that stage. Have tried running it as an administrator.
     
  3. Terradive

    Terradive Warlord

    Joined:
    Jun 4, 2009
    Messages:
    186
    zulu9812 - I just used the SVN instructions to get the mod. Using Afforess's instruction download on the previous page also failed for me.
     
  4. 45°38'N-13°47'E

    45°38'N-13°47'E Deity

    Joined:
    Jun 7, 2008
    Messages:
    5,974
    Location:
    Just wonder...
    Or if you have it, you can simply open and extract it with WinRar as I did. :)
     
  5. Maatissi

    Maatissi Turvenuija

    Joined:
    Oct 3, 2006
    Messages:
    143
    Location:
    Jyväskylä, Finland
    Does this update overwrite all xml files? Could there be a list of files an update overwrites or perhaps an option to view the contents of the installer file?

    Also, could you please answer my previous question regarding editing the buildinginfos.xml file/buildings in the mod?

    Thanks.
     
  6. JosEPh_II

    JosEPh_II TBS WarLord

    Joined:
    Jun 20, 2007
    Messages:
    16,513
    Gender:
    Male
    Location:
    Western IL. cornfields
    No

    If you use the SVN route to get the Mod it also will tell which files got updated and which got deleted or added.

    JosEPh :)

    Edit: Am now at 455 BC and have reached the Medieval era. NO CTDs to report. Mod seems to be moving along at a good pace. Stalin just DOW'd me but I had some tri's in good position to kill his loaded galleys. We'll see how long he'll try to wage an ocean going war. His Northern shore looks good for a city or 2. And Shaka is just south of him. The Khmer share my Archipelago and this will inevitably get ugly. But right now we are "chums". :rolleyes:
     
  7. Maatissi

    Maatissi Turvenuija

    Joined:
    Oct 3, 2006
    Messages:
    143
    Location:
    Jyväskylä, Finland
    -Thank you for your answers. (I noticed the installer could be opened also with WinZip...) :D

    I'm worried with compatibility as I've made many changes on my own. Apparently there are changes to unitinfos.xml, so would this new version work without installing the new xml's? (all the other features eg. improved AI etc.)

    ALSO:

    I'm still wondering how does one edit buildings in AND? :confused:
    Any changes I make to the buildinginfos.xml in /assets/xml/buildings/ do not take place in gameplay.
     
  8. Afforess

    Afforess The White Wizard

    Joined:
    Jul 31, 2007
    Messages:
    12,239
    Location:
    Austin, Texas
    Thanks, I'm assuming you don't mind if I borrow it. ;)

    I flipped an option in the global defines to always use max comp saving. There is no reason to have it off, IMO.

    :)

    Others -

    Looking into Installer woes. Have a fix up soonish I hope.
     
  9. Terradive

    Terradive Warlord

    Joined:
    Jun 4, 2009
    Messages:
    186
    Make sure the changes you are making are to the mod folder Beyond the sword/mods/riseof mankind. Try clearing your cache.
     
  10. Afforess

    Afforess The White Wizard

    Joined:
    Jul 31, 2007
    Messages:
    12,239
    Location:
    Austin, Texas
    Thanks, fixed for the next release.
     
  11. aswfreak12

    aswfreak12 Chieftain

    Joined:
    Nov 20, 2007
    Messages:
    49
    Pretty much a constant OOS after 198ish. Every turn. Haven't figured out what might be causing it though. Have IDW off along with every other influence thing off. No ranged bombardment. Might be Revolutions, but it wouldn't be every turn.
     
  12. Afforess

    Afforess The White Wizard

    Joined:
    Jul 31, 2007
    Messages:
    12,239
    Location:
    Austin, Texas
    If you turn on all the logging in the Civilization ini files, repeat the OOS, and send me the logs for both computers, I can track it down.
     
  13. aswfreak12

    aswfreak12 Chieftain

    Joined:
    Nov 20, 2007
    Messages:
    49
    Which files do I mess with precisely?
     
  14. Afforess

    Afforess The White Wizard

    Joined:
    Jul 31, 2007
    Messages:
    12,239
    Location:
    Austin, Texas
    Civilization ini files are in:

    Documents/My Games/Beyond the Sword
     
  15. aswfreak12

    aswfreak12 Chieftain

    Joined:
    Nov 20, 2007
    Messages:
    49
    Do you want all the logs from the /Beyond the Sword/logs directory? Where do I send them too?
     
  16. TomSawyer

    TomSawyer Chieftain

    Joined:
    Nov 5, 2005
    Messages:
    48
    Afforess

    Thanks for keeping Civ 4 alive. I loaded your mod and everything was great but then I experienced one of the mysterious crash to desktops. It occurs every time at the same turn. I have uploaded my dump file in the hopes it may help squash the bug.

    If you want the latest save file and it can help let me know.

    Cheers
     

    Attached Files:

  17. JosEPh_II

    JosEPh_II TBS WarLord

    Joined:
    Jun 20, 2007
    Messages:
    16,513
    Gender:
    Male
    Location:
    Western IL. cornfields
    @Afforess,
    Aline has a mindump posted in post #4200 in case you missed it.

    I know "nag, nag, nag"! :D

    JosEPh ;)
     
  18. TomSawyer

    TomSawyer Chieftain

    Joined:
    Nov 5, 2005
    Messages:
    48
    From the themeparse log:

    [Jan 21, 2012 - 20:24:37] Messages while processing 'Mods\A new dawn\Assets\modules\Interface Colors\Forest UI\Resource/Civ4.thm'

    Error : Syntax - ('Civ4Theme_Common.thm', Ln:211, Col:1) Unexpected '27' in the identifier assignment statement
    Error : Decl - ('Civ4Theme_Common.thm', Ln:401, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size3_Italic' not found
    Error : Decl - ('Civ4Theme_Common.thm', Ln:402, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size3_BoldItalic' not found
    Error : Decl - ('Civ4Theme_Common.thm', Ln:408, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size1_Bold' not found
    Error : Decl - ('Civ4Theme_ComboBox.thm', Ln:1347, Col:25) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_ComboBox.thm', Ln:1346, Col:59) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Edit.thm', Ln:157, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Decl - ('Civ4Theme_Menu.thm', Ln:446, Col:21) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Menu.thm', Ln:445, Col:55) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Menu.thm', Ln:733, Col:21) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Menu.thm', Ln:732, Col:55) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Menu.thm', Ln:744, Col:21) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Menu.thm', Ln:743, Col:55) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Menu.thm', Ln:755, Col:21) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Menu.thm', Ln:754, Col:55) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Table.thm', Ln:142, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Decl - ('Civ4Theme_Table.thm', Ln:2085, Col:25) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Table.thm', Ln:2084, Col:59) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Table.thm', Ln:2179, Col:25) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Table.thm', Ln:2178, Col:59) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Table.thm', Ln:2268, Col:25) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Table.thm', Ln:2267, Col:59) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Table.thm', Ln:2390, Col:25) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Layer - ('Civ4Theme_Table.thm', Ln:2389, Col:59) 'FactorColor' tag not found in layer, required if using 'FactorCombine'
    Error : Decl - ('Civ4Theme_Window.thm', Ln:3048, Col:9) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size1_Bold' not found
    Error : Decl - ('Civ4Theme_Custom.thm', Ln:4286, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Color_Select' not found
    Error : Syntax - ('Civ4Theme_HUD.thm', Ln:887, Col:13) Unexpected '.' in the identifier assignment statement
    Error : File - ('Civ4Theme_HUD.thm', Ln:924, Col:47) Could not load bitmap '../Beyond the Sword/Resource/Civ4/HUD/HUD_BTS_icons.tga'
    Error : File - ('Civ4Theme_HUD.thm', Ln:925, Col:47) Could not load bitmap '../Beyond the Sword/Resource/Civ4/HUD/HUD_BTS_icons.tga'
    Error : Syntax - ('Civ4Theme_HUD.thm', Ln:927, Col:13) Unexpected '.' in the identifier assignment statement
    Error : File - ('Civ4Theme_HUD.thm', Ln:928, Col:47) Could not load bitmap '../Beyond the Sword/Resource/Civ4/HUD/HUD_BTS_icons.tga'
    Error : File - ('Civ4Theme_HUD.thm', Ln:929, Col:47) Could not load bitmap '../Beyond the Sword/Resource/Civ4/HUD/HUD_BTS_icons.tga'
     
  19. OrionVeteran

    OrionVeteran Deity

    Joined:
    Dec 25, 2003
    Messages:
    2,443
    Location:
    Newport News VA
    Afforess,

    Where is the official link to the source files for ROM AND?
     
  20. Afforess

    Afforess The White Wizard

    Joined:
    Jul 31, 2007
    Messages:
    12,239
    Location:
    Austin, Texas
    Saves are more useful than minidumps, can I have saves please?
     

Share This Page