1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Again 3.19... sorry!

Discussion in 'Civ4 - Fall from Heaven' started by mportela, Jul 4, 2009.

  1. mportela

    mportela Chieftain

    Joined:
    Dec 29, 2008
    Messages:
    8
    Hey all,

    I'm a FfH2 fan, and a Fall Further user... I decided to go for the 3.19 patch since I would be able to play FfH (bad move):eek:

    With all successfully installed the BtS 3.19 vanilla worked like a charm... now when i run a FfH 3.19 enabled vanilla mod it crashes on load (something about a cvgamecoredll.dll)

    Just to be sure I even triedother mods that are 3.19 ready... same problem.

    Does anyone have a clue on what's wrong?:confused::confused:
     
  2. xienwolf

    xienwolf Deity

    Joined:
    Oct 4, 2007
    Messages:
    10,589
    Location:
    Location! Location!
  3. Cyberblade

    Cyberblade Chieftain

    Joined:
    Aug 27, 2007
    Messages:
    45
    this is what keeping me to use 3.17 and having to dealwith the broken leaderheads...

    so i have a few questions xd...

    If i download 3.19 from civfanatics i wont need a cd right, cause my cd is nearly broken so its been in my drive for the last year.

    And then when i download FFH2 and install it from the 300meg installer it will all work fine?
     
  4. mportela

    mportela Chieftain

    Joined:
    Dec 29, 2008
    Messages:
    8
    I did use the CFC exe for the 3.19 install. I also reinstalled everything from scratch just to be sure... and again the same error. A vanilla BtS runs as intended but no mods can be loaded be it using the advanced option or a direct shortcut.

    I also tried to re-install the exe and it claims it's installed already and asks if I want an uninstall.

    Any other ideas?:(
     
  5. xienwolf

    xienwolf Deity

    Joined:
    Oct 4, 2007
    Messages:
    10,589
    Location:
    Location! Location!
    Uninstall/Reinstall FfH 0.41, do not patch it. See if that runs. If it does, then you still aren't on 3.17 somehow. If it doesn't, something else is going on and rather strange. But since ALL mods are broken it would seem most likely that BtS is the one at fault.

    Cyberblade: Yes, installing 3.19 makes you not need a disc anymore. If you download from here and install then you will never have needed to start the game, so would be fine even if at this moment your CD was completely unreadable.
     
  6. mportela

    mportela Chieftain

    Joined:
    Dec 29, 2008
    Messages:
    8
    Still no luck! :mad:

    Thanks for your time on trying to lend a hand here. :)
    Any other suggestions?
     
  7. Cyberblade

    Cyberblade Chieftain

    Joined:
    Aug 27, 2007
    Messages:
    45
    that still didnt answer one of my questions so ill ask again, albeit better worded thistime

    I just re downloaded the full installer for FFH2 on the page here on civfanatics it says required 3.19. but in the installer 3.17. This is making me wonder if i can install 3.19 and FFH2 will still work?
     
  8. Kael

    Kael Deity

    Joined:
    May 6, 2002
    Messages:
    17,401
    Location:
    Ohio
    FfH 0.41b requires BtS 3.19.
     
  9. Cyberblade

    Cyberblade Chieftain

    Joined:
    Aug 27, 2007
    Messages:
    45
    Thanks for the Clarification Kael, and great work!
     
  10. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,922
    Load BtS, and at the main menu choose "ADVANCED", then choose "ABOUT THIS BUILD". The line "Civ Version:" in the "About Beyond the Sword" window that opens will read "317" for v3.17, or "319" for v3.19. That will tell you whether the game was patched successfully.

    FfH2 v0.41 & v0.41a require BtS v3.17, and will crash if v3.19 is installed. FfH2 v0.41b requires BtS v3.19, and will crash if launched under v3.17. Make sure you are using the correct version of FfH2 to match your version of BtS.

    If you also play Fall Further then you should be aware that you won't be able to play it using BtS v3.19 (until FF051 is released). You can play FF050 with FfH2 0.41a + BtS 3.17 + WarKirby's Broken Art Fix.

    -------------

    The corrupted leaderheads problem was fixed in one of the 0.41 installer releases, not in patch B. You don't need to upgrade to v3.19 to correct that problem, and I don't think that upgrading BtS and patching to 0.41b will correct it. You need to get a version of the FfH2 installer that has the corrected leaderheads. Try to find the 376,681 KB version of "FallfromHeaven2.exe".
     
  11. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,922
    A new FfH2 installer is now linked in the first post of the Bug Thread. This installer includes the version of 0.41 with corrected leaderheads, plus patch C. Downloading and reinstalling using that installer, named "FallfromHeaven2041c.exe", should correct the corrupted leaderheads problem. You should also download and install patch D, because that corrects a serious bug in patch C.
     
  12. Kael

    Kael Deity

    Joined:
    May 6, 2002
    Messages:
    17,401
    Location:
    Ohio
    This is all correct except the file is now called "FallfromHeaven2041d.exe" as it includes patch "d".
     

Share This Page