1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Although my modifiers show up in firetuner, they don't seem to be doing anything.

Discussion in 'Mod Creation Help' started by Homusubi, Feb 5, 2018.

  1. Homusubi

    Homusubi Lafcadio Hearn Wannabe

    Joined:
    Dec 21, 2012
    Messages:
    1,035
    Here's the relevant code. Any idea what I'm doing wrong? (And yes, there are most likely schoolboy errors and so forth, don't assume I know that much)

    upload_2018-2-5_21-19-21.png

    It is supposed to make all of the civ's trading posts provide one extra science, and for international trade routes to the civ to give one science to the receiver and two culture to the sender. However, none of these effects actually works ingame.

    EDIT: so I realised I've used the wrong modifier with send_culture and receive_science, but even after I corrected it, it doesn't actually do anything when I try and send a trade route to a city controlled by my custom civ. Remember that I haven't done ANYTHING modifier related other than what is in the screenshot, plus attach the trait to the civ and add the file to In-Game Actions/UpdateDatabase.
     
    Last edited: Feb 6, 2018
  2. Homusubi

    Homusubi Lafcadio Hearn Wannabe

    Joined:
    Dec 21, 2012
    Messages:
    1,035
    Hmm, the modifiers now seem to be working for some reason! Perhaps something was fixed behind the scenes in the R&F patch?
     

Share This Page