1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

ATI9800 crash, reboot - contd.

Discussion in 'Civ4 - Bug Reports' started by Behdahh, Feb 28, 2006.

  1. Behdahh

    Behdahh Chieftain

    Joined:
    Feb 28, 2006
    Messages:
    1
    I know it has been posted a thousand times all over the web and in this forum of course, but i wasn't able to find a working solution to the random-crashy behavior of ATI9800 in CIV4.

    Here is my system config:
    AMD 3500 64 bit
    Asus A8V deluxe
    Club 3d ATI 9800
    2x512 Kingston 3200 DDR
    OS: I tried both XPsp2 and XPx64 all clean fresh installs
    Newest MoBo and Graphics drivers (even tried Omega drivers under XP32), newest peripheral drivers, ieven tried older ones - just in case...
    Bios settings: I tried almost anything i could get out of forums (including fast writes off, AGP 4x, just using 1 RAMbank, Using 1.6V for AGP, disabling peripherals etc. - I really tried any possible setting except overclocking, the system has never been overclocked btw.)

    I tested the system 2 complete days with several Burn-In tests and benchmarkers - anything is stable, no heat problems.
    I tried Civ with and without the Civ-Patch v. 1.52

    And still when I play civ4 after a few minutes (randomly; varies between 30 secs and 40 minutes) the game crashes - also randomly system reboots or just kicks me back to desktop or i get a nice blue screen telling me that memory has been dumped. The behavior also occurs when i just start the game, open a savegame (or new one) and leave it alone without even moving the mouse. I installed clean, licensed OS-Versions without installing any further software than the required drivers and Civ4. DxDiag says anything is ok and up to date, all tests succeed.

    If someone found a solution to that nasty problem please tell me. Perhaps there is a special Direct3d-Command which is not compatible with my Setup (but not detected or used by 3d-benchmarkers)? Which game-settings should I try if this is the case? Does someone know a testing or benchmarking tool, that uses the same DX-commands as Civ4 does - it could help to identify the problem.
    Thanx for your help!
    Behdahh
     
  2. Drondoth

    Drondoth Chieftain

    Joined:
    Mar 3, 2006
    Messages:
    1
    I have the same system, Just picked up this game today and patched to 1.52 I carnt play for no longer then 10 mins in single player mode and when I played the tutorial it keeps crashing at the point it teaches about making trade routes every time.

    Big Disapointment any fix??
     
  3. danielcg

    danielcg Chieftain

    Joined:
    Mar 6, 2006
    Messages:
    23
    While you updated motherboard driver and graphics driver, did you update your A8V BIOS? This BIOS may need to be updated to fix the bug with ATI related cards.

    Then in Civ IV's option, set render quality to MEDIUM and restart Civ IV so it will use ATI driver's pixel shader instead of internal pixel shader.

    I don't have any issues with my Nvidia GeForce 6800 and Forceware 84.12 but had to reduce render quality to medium to workaround minor bug that involve mouseover tooltip on selection item popup.
     
  4. AsnoT

    AsnoT Mostly Civilized

    Joined:
    Apr 11, 2003
    Messages:
    227
    Location:
    Austria
    please see THIS thread for an explanation
     
  5. auldian

    auldian King

    Joined:
    Nov 5, 2004
    Messages:
    648
    Location:
    Alaska, USA
    I resolved it by updating my chipset drivers, using official 5.11 CCC drivers, and reinstalling the December DirectX 9.0c.
    I delete my Civ4\cache pretty often also. I've been playing without reboots for several months.
     

Share This Page