1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Black triangles and squares appearing on map

Discussion in 'Civ4 - Technical Support' started by ThunderMohawk, Nov 5, 2012.

  1. ThunderMohawk

    ThunderMohawk Chieftain

    Joined:
    Sep 16, 2012
    Messages:
    19
    For some reason my game has begun to have these odd squares and triangles appear all over the screen. They are usually black colored and all across the map. They get bigger as I zoom out. I'm unsure if those are a setting but I tried to turn up all graphics and it did nothing. All the graphics are distorted on the map and when talking to leaders. But they go away for a second when events occur like techs and founding cities. The grass grew giant once and idk why but these large stretchy lines appear too. I've never used mods or anything that could harm the game. In fact I don't even play civ IV much since I have Civ V. So wondering if I should just uninstall the game or if there's a simpler solution to this issue.

     
  2. Darkspire

    Darkspire Chieftain

    Joined:
    Nov 6, 2012
    Messages:
    7
    Looks like your GFX card might be on the way out, hope im wrong but if you try another game with a similar graphics engine that might give you the answer, If not then try the drivers? Is the GFX card compatible with Civ4?

    Darkspire
     
  3. ThunderMohawk

    ThunderMohawk Chieftain

    Joined:
    Sep 16, 2012
    Messages:
    19
    I uninstalled the game and then installed it and there was no difference. I have no idea how graphic cards work or whether mine is having problems. How can I figure this out?

    UPDATE: This is my graphic card information.
    Graphics
    --------------------------------------------------------------------------------

    Display adapter type ATI Radeon HD 3400 Series
    Total available graphics memory 1663 MB
    Dedicated graphics memory 256 MB
    Dedicated system memory 0 MB
    Shared system memory 1407 MB
    Display adapter driver version 8.961.0.0
    Primary monitor resolution 1024x768
    DirectX version DirectX 10


    It seems Civ City Rome has the same issue.
     
  4. jarhead_leif

    jarhead_leif Civ2ToT Modder

    Joined:
    Feb 1, 2012
    Messages:
    713
    Location:
    Philippines
  5. Padjur

    Padjur Prince

    Joined:
    Nov 16, 2009
    Messages:
    318
    It does seem you have a graphics card problem, the best way to test it, is to replace the card with one that is known to work, if the problem is fixed you know its the card.
    Otherwise try other games etc see if you get the same problem.

    If you have the same problem on Civ City that's not good,
    update the drivers to the latest version (12.6 for 32bit vista for HD3000 series cards) download and install the latest version of DirectX 9.
    If it still doesn't work, consider how best to upgrade your graphics card.
     
  6. Zen Blade

    Zen Blade Warlord

    Joined:
    Oct 31, 2008
    Messages:
    247
    I just started to get this on my Civ IV...

    Yesterday I used steam to "update video drivers"... I have no clue if this is related or not, anyone have any thoughts or ideas?

    My computer is ~5.5 years old. If I try to adjust graphic settings in game (specifically the AA settings...) at first the triangles aren't there, but as everything gets "re-rendered"? they show up at the end.

    Thanks in advance.
     

Share This Page