1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Broken Techtree and ways to fix it.

Discussion in 'Civ 5 - Community Call to Power project' started by Gilgamesch, Sep 5, 2013.

  1. Gilgamesch

    Gilgamesch Ancient Alien

    Joined:
    Dec 15, 2010
    Messages:
    2,228
    Location:
    good old germany
    Hey all,
    we all now modern era is broken, and thats a mess.
    Well i think i figured out why ths happened.
    Code:
    local g_PipeRevolutionaryWarfare = InstanceManager:new( "TechPipeInstance", "TechPipeIcon", Controls.RWTechTreeScrollPanel );
    local g_TechInstanceRevolutionaryWarfare = InstanceManager:new( "TechButtonInstance", "TechButton", Controls.RWTechTreeScrollPanel );
    local g_PipeMolecule = InstanceManager:new( "TechPipeInstance", "TechPipeIcon", Controls.MoleculeTechTreeScrollPanel );
    local g_TechInstanceMolecule = InstanceManager:new( "TechButtonInstance", "TechButton", Controls.MoleculeTechTreeScrollPanel );
    local g_PipeEnvironment = InstanceManager:new( "TechPipeInstance", "TechPipeIcon", Controls.EnvironmentTechTreeScrollPanel );
    local g_TechInstanceEnvironment = InstanceManager:new( "TechButtonInstance", "TechButton", Controls.EnvironmentTechTreeScrollPanel );
    local g_PipeElectrical = InstanceManager:new( "TechPipeInstance", "TechPipeIcon", Controls.ElectricalTechTreeScrollPanel );
    local g_TechInstanceElectrical = InstanceManager:new( "TechButtonInstance", "TechButton", Controls.ElectricalTechTreeScrollPanel );
    local g_PipeMolecules = InstanceManager:new( "TechPipeInstance", "TechPipeIcon", Controls.MoleculesTechTreeScrollPanel );
    local g_TechInstanceMolecules = InstanceManager:new( "TechButtonInstance", "TechButton", Controls.MoleculesTechTreeScrollPanel );
    The problem is related to TechtreeBFFT. When Chrome tried to implend a new era, he has done some replacing error or what ever.
    All colllums in the whole lua file are coded with RevolutionaryWarfare, Molecule, Environment... and again Molecule.
    This causes the problem with not able to accessing the modern era techtree.
    Didnt fond any relatin of this changes in any other technology file.
    Sadyly i failed yester day, with fixing it.
    Dont know why but my modbuddy seems buggy.
    Got some problems with duplicated files, that are both working in the database.

    Maybe this news, could help you Fires to fix the current problem:thanx:.
    This would be so very helpfull. You did a great code , i think i understand the mechanism, but for any reason it doesnt worked for me.



    Edit @Fires you work is 3 years old but sill the best in CiV, have you find a way to bring back also mutiple policy pages?
    best wishes
    Gilga
     
  2. TanisX

    TanisX Warlord

    Joined:
    Nov 5, 2010
    Messages:
    113
    I looked into this and found a missing era that should be inbetween Industrial and Modern eras: RevolutionaryWarfare, Molecule, and Environment. So there are two different techtrees Molecule and Molecules. I removed the 3 missing era techtrees and changed the values for subsequent techtrees and Modern era partially works now. The techs from the missing era now appear off to the side and not connected or connected incorrectly to the techtrees in Military research, Electrical Phenomena, and Molecules.
     

    Attached Files:

  3. Gilgamesch

    Gilgamesch Ancient Alien

    Joined:
    Dec 15, 2010
    Messages:
    2,228
    Location:
    good old germany
    Cool:scan:

    Will check if it works for me, will post if not.
    So also tomorrow i will code the next eras.
    Many new techs, looks all so new, got CCTP complete clean uped.

    Oh my spelliing today, all worked fine.
    So got the techtree fixed till industrial.
    Will have a look where i can manage some wonders in the future eras.
     

Share This Page