1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

BTS crashes at 'init engine" on start-up

Discussion in 'Civ4 - Technical Support' started by TSuperBrains, Feb 19, 2017.

  1. TSuperBrains

    TSuperBrains Chieftain

    Joined:
    Jan 14, 2012
    Messages:
    2
    I'm on Windows 8.1 and I have played this game just fine before. Today I decided to go back to it but it simply won't start. It goes to the loading screen and it gets to the Init Engine step and it simply crashes. It says the game stopped working, but it doesn't give me an error code or anything.

    I have tried every compatibility mode. I am running as admin. Both my OS and my GPU are up to date. I even did a clean install 3 times today alone. Yes my game is on 3.19.

    I have scourged the internet for a fix but literally everyone with the same problem as me ends up not having any answers to their threads.
     
  2. TSuperBrains

    TSuperBrains Chieftain

    Joined:
    Jan 14, 2012
    Messages:
    2
  3. tomtomkenobi

    tomtomkenobi Chieftain

    Joined:
    Dec 25, 2009
    Messages:
    3
    Exactly the same here. It's been working for me for the past 3 months, but now it's back to this. My game crashed during a game and now I can't open it.
     
  4. eru001

    eru001 Chieftain

    Joined:
    Yesterday
    Messages:
    1
    Gender:
    Male
    same problem here. would really appreciate a solution as Civ 4 has been one of my favorite games for a long time. I'm running it through steam if that helps.
     
  5. elitetroops

    elitetroops Chieftain

    Joined:
    Dec 23, 2012
    Messages:
    4,748
    I had that problem a few weeks ago and it was fixed by switching from the disk version to Steam version (if you have the disk, you can get Steam version for free).

    But if you already are running it through Steam, then I have no idea...
     

Share This Page