[Bug] Hex yield icons incorrect

ErwinMoller

Chieftain
Joined
Mar 21, 2007
Messages
1
Hi,

My yield icons are often displayed in the wrong tile. Highly confusing. ;-)

I attached both a save-game and a screenshot.
Two examples demonstrating wrong yields (look at screenshot):
- example 1: The coal next to Buffalo Creek is displayed one hex left-down from where it should be.
(Also note that is appears as 10 food-yields, instead of 10 hammers.)
- example 2: Look in the upper left part (right above new york): you will see the 2 science-output of a jungle misplaced too.

This seems to happen to many yield-icons.

Set-up/system
I run via Steam, using DirectX10/11 option, have updated drives on my ATI RADEON 5700 HD, and my OS is Win7 Home Premium.

I couldn't find this exact bugreport in the confirmed buglist, but I found a few similar bugs.
Also, reloading, restarting doesn't solve it.

Regards,
Erwin Moller

Moderator Action: Merged with the main thread about this issue.
 

dr.Hyde

Chieftain
Joined
Jul 18, 2009
Messages
47
version 6.1.7601. Installed G&K not long ago and played with no mods so far. I ran into this bug in my second game on earth map, large size. Started at South America and when I captured 2 CS in Australia, one of them looks like it has tile production 'shifted' to the south east. Another one I saw was near Japan and another in Kamchatka area. Most of the other map looks fine though.

I tried workaround posted in this thread and it works fine, but I also noticed that you don't actually have to save anything. All you have to do is to turn off yield display with 'y' key before you exit the game. Doesn't matter if you save before or after that, or save at all. When you load the game, it will remember last 'yield display' setting and will start with it disabled since you turned if off before you exited game.
In a nutshell, if the game loads with 'yield display' turned off, it will show tiles correctly when you turn it on. However if you had it on when you exited, the tiles will show 'shifted' when you load game.

I'd say this is not a save game problem at all, you can make any save work properly or bugged just by turning on or off 'yield display' before you exit the game.

This is probably why some admins didn't get this bug at the start, but did after they checked it again. Save game itself isn't bugged so they started with 'yield display' off and didn't see any bug. When they tried it again, the 'yield display' probably remained on from last test and the bug showed up.

Hope this info helps in fixing this annoying bug.
 

bcaiko

Emperor
Joined
May 9, 2011
Messages
1,412
Location
Washington, DC
This certainly happens to me, as well, and I have to turn off my yields to avoid confusion. It's pretty annoying.
 
Top Bottom