Bug Reports (not related to Heroes of the Agean)


Archiving Civ3 Content
Mar 17, 2007
I'm creating a thread for bug reports, since two of the three times I've tried to report one in-game, the bug reporter has failed to send the report.

There probably is a more official place to report these, but I'm probably not the only person who is active on this forum but isn't on the official place (other than the bug reporter). And I know a couple of the Mohawk guys browse here, so we can figure out where they go - the first thing is remembering to write them down!

A few I've noticed, which haven't succeeded at sending via the bug report system:

1. The bug reporter doesn't always work. At least on the GOG version, it has failed 2/3 times for me. Could be related to the length of the text? Not sure, but the second time it failed was immediately after it succeeded the first time.
2. I got the Horreum event, where a governor suggested building one, but it got placed in the capital instead of the governor's city. I can see why some events may affect the capital instead of the local province (e.g. I got a local artist one where I could recruit him to the capital), but this one didn't make sense.
3. The bug report system takes a long time to load, and while it looks like it should support multiple lines, it doesn't. Also, AFAIK there's no way to get a screenshot for it within a city screen/with the text of an event. Not sure if it's a bug, but it could be better. All in the GOG version.
4. The GOG version never seems to succeed at syncing. I keep getting noticed for completing old achievements whenever I start, probably as a result. Can't find a way to disable syncing. I suspect it might be trying to sync saves, and they're too large, but have no way of knowing for sure.

Hopefully this can be directed to the proper place... especially for the Horreum I would have forgotten about it if I didn't write it down soon.
I keep getting noticed for completing old achievements whenever I start, probably as a result.

I've been trying to track down some info on this. I know the achievements will show up in your Galaxy client, but if you check one of these repeated achievements in your profile on gog.com, does it show up as locked or unlocked there?
I've been trying to track down some info on this. I know the achievements will show up in your Galaxy client, but if you check one of these repeated achievements in your profile on gog.com, does it show up as locked or unlocked there?

Interesting, just checked two of them that show as being completed today - Riders and Fountainhead - and they don't show as being completed in the list of achievements for Old World.



And looking more closely, the 6 achievements from the most recent two blocks include five duplicates:

- Fountainhead
- Strong Cities (the description has it spelled "string cities", but the title is correct)
- Necropolis
- Riders
- Good

The other two were actually new in my two most recent sections.

Three days ago the same five, minus Riders, show up.

The first one of those I got was "Good", 11 days ago, playing Tutorial 4. It showed up again 8 days ago when I played Tutorial 5. None of the others show up in tutorial results.

Necropolis, Strong Cities, and Fountainhead (along with another Good) show up for the first time 4 days ago. Several others, e.g. Developing Cities, show up that don't repeat thereafter.

I didn't get Riders until two days ago. It has repeated both times since.

Not sure whether it's specific to these five or just a coincidence/something about the sync. :dunno: Perhaps worth noting, the sync did succeed this time, and the just-exited session did not result in another group of achievements being posted. Maybe the successful sync fixed it?
Even more interesting because Necropolis, Good and Riders have been in my list when I saw that...

What's a sync exactly in GOG, where do you see that it's syncing and whether it succeeded or failed?
I'm not an expert on how GOG syncs work, as to my knowledge Old World is the first game I've played that uses them. Most of my GOG library is good old games, and I can only think of a couple others I've played that have achievements enabled on GOG.

What I see currently (out of game) is this:


I got a toast notification that it had failed shortly after exiting Old World (less than a minute).

This time I got 3 new achievements and only those three posted to the "Activity" section.

If I click "Play", I get this message:


Sometimes, the GOG Galaxy Cloud one has been older than the "This Computer" one. I'm not sure exactly why it says the sync failed when the timestamps match. Wouldn't be too surprised if it's a GOG backend issue, at least in part, but I don't have anything to compare it to.

So far I've only played on one computer, so there isn't any downloading/reuploading going on.
I'm fine either way. We try to have too few bugs to warrant a subforum ;)

For bugs that happen in-game it's usually best to use the in-game reporter as that also forwards us logs automatically.
That is if it works, for Quintilius it dosn't seem to work. I get the sync problem in some other games. It always results from saves to the cloud. If I have a choice, I disable the damn thing.
UPDATE: This was fixed by the patch that was released the following day. Awesome job fixing it, Mohawk!

Spoiler Obsolete Bug Report :
Not sure if this got auto-logged or not, but I have a situation where I end the turn, the AI plays there turn, but on my turn I get one event, but no orders back, no science progress, and can't do anything other than hit End Turn again, at which point the game never resumes. It's not frozen per se, just the actions die out.

Here's the event, not sure if it's related.

Spoiler :

AgentCaught - GameCaughtToo.png

Attached is the log. This is my third attempt to play the turn with identical results. There is an error in the log:

------------------- Error ----------------------------
03:18 - TaskManager Exception in RunTask: System.NullReferenceException: Object reference not set to an instance of an object
  at TenCrowns.GameCore.Tile.isFreshWaterSource () [0x00010] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Tile.isFreshWaterAccess () [0x00024] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.isValidSubjectAnyTile (TenCrowns.GameCore.SubjectType eSubject, TenCrowns.GameCore.Tile pTile) [0x001ee] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.isValidSubjectTile (TenCrowns.GameCore.SubjectType eSubject, TenCrowns.GameCore.Tile pTile) [0x00099] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.isValidEventSubjectTile (TenCrowns.GameCore.EventStoryType eEventStory, TenCrowns.GameCore.Tile pTile, System.Int32 iIndex) [0x00067] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.findEventStoryBestSubjectsLink (System.Collections.Generic.List`1[T] lSubjectsPrevious, TenCrowns.GameCore.EventStoryType eEventStory, System.UInt64 ulSeed, System.Object pTriggerSubject, System.Object pTriggerExtra, System.Collections.Generic.List`1[T] lLinkSubjects) [0x00d7c] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.findEventStoryBestSubjects (System.Collections.Generic.List`1[T] lSubjects, TenCrowns.GameCore.EventStoryType eEventStory, System.UInt64 ulSeed, TenCrowns.GameCore.EventLinkData& pEventLink, System.Object pTriggerSubject, System.Object pTriggerExtra) [0x003f1] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.doEventTrigger (TenCrowns.GameCore.EventTriggerType eTrigger, System.Object pTriggerSubject, System.Object pTriggerExtra, System.Int32 iTriggerData, System.Boolean bModal, System.UInt64 ulSeed, TenCrowns.GameCore.EventClassType eClass, TenCrowns.GameCore.EventLinkType eLink, System.Boolean bTest) [0x00300] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.doEventTriggers () [0x00129] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.processTurn () [0x0090e] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Player.doTurn () [0x00018] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Game.nextTeamTurn () [0x000ea] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Game.testTurn () [0x00015] in <a580da2fb6354a7999a513559aab75ad>:0
  at TenCrowns.GameCore.Game.updateServer () [0x00035] in <a580da2fb6354a7999a513559aab75ad>:0
  at GameServerBehaviour.UpdateOnce () [0x0001e] in <14eb9df81d344f7eb0f7cbb8544b3e58>:0
  at GameServerBehaviour.UpdateLoop () [0x00005] in <14eb9df81d344f7eb0f7cbb8544b3e58>:0
  at Mohawk.SystemCore.TaskManager.RunTask (System.Func`1[TResult] task) [0x00028] in <ddc00247736d4793b704b585c1177839>:0

And the most recent autosave. It should be possible to reproduce it just by ending the turn.

Hopefully it's fixable. It was just getting good again too, Assyria having the audacity to demand I break my alliance with the Hittites. Of course we told them no way, but now we have to actually respond militarily, and hopefully before they wipe out the Hittites.

I've backed up the previous couple auto-saves as well, if they would be of any assistance.


  • output - freezeup.txt
    5.1 KB · Views: 22
  • OW-Save-Auto-3 - Persia.zip
    524.9 KB · Views: 22
Last edited:
Not sure if it's scenario related or just a random fluke, but here something seems to wrong with (only - no gameplay impact) the text for the "Eloper Captured" event - what's the deal with the Roman consul being named as lover of the princess in the text, when she has eloped with Iboham (who is correctly targetted when choosing an outcome)?


  • EloperCaptured1.jpg
    428.5 KB · Views: 31
  • EloperCaptured2.jpg
    431.7 KB · Views: 37
Thanks, that's a generic event bug - the text and the option were meant to refer to Iboham and not Scipio.
Using Steam and the in game bug report did not work.

Carthage Scenario 3: Goals: Seize Syracuse!
The goal does not complete on capture of the city. Tried reloading save from the turn before selecting a different family to control the city but the goal does not update. The attached save is the turn before capture. Perhaps relevant, I did not kill all the Greek units prior to capturing the city and they converted to barbarians with a notification that Greece had been eliminated. I also changed which unit was occupying the city hex during the capturing countdown. If there is a work around for this, would be great to know. I have fun hunting the achievements. Was having a solid game, expecting to be at 11/12 goals completed on turn 31 of 60.


  • RiseOfCarthage-GameThree-Turn30ShouldCapSyracuse.zip
    169.8 KB · Views: 22
That goal has been a pain in the rear in more than ways than one.

Here's a fixed save, the goal should complete if you continue from this one.


  • RiseOfCarthage-GameThree-SyracuseEdit.zip
    169.5 KB · Views: 22
The famous free floating lumbermill, presumably a part of ancient log driving industry :)


  • lumbermill 1.png
    lumbermill 1.png
    4.3 MB · Views: 25
  • lumbermill 2.png
    lumbermill 2.png
    4.5 MB · Views: 25
The famous free floating lumbermill, presumably a part of ancient log driving industry :)
You're lucky I know these maps so well, I could within about 15 seconds work out which map and where on the map you are. :mischief:

On the development build, I keep getting the following bits of code error in red text.
This is build number whatever the current test build is (updated this morning) although I saw this on the last test build as well.
Strange Game code errors.jpg
Strange Game code errors 2.jpg
Top Bottom