1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Can only start FfH2

Discussion in 'Civ4 - Bug Reports' started by HahnHolio, Sep 3, 2008.

  1. HahnHolio

    HahnHolio Warlord

    Joined:
    May 15, 2004
    Messages:
    138
    Location:
    Germany
    well hiho!

    i got this wierd problem, when i try to start BtS (or any other mod for it)
    i get a CtD while initialitzing XML.
    But i can start BtS with FfH2!!!

    ne1 an idea what could be causing this?
    i have cleaned the customassets folder and tried to start BtS without any mod, but to no avail :(

    Thx in advance

    Machine ifo: AMD X2 3800+, 2 Gig, Dual 7800GTX running BtS 3.17.

    EDIT: Ok i got the prob sorted out with reinstalling patch 3.17!!!
     
  2. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    I have this same problem. BtS doesn't even start up. It stops to the XML something. FfH II starts very well but it crashes after I press 'Play'.

    Do I need to do something else than simply download 3.17 patch (I have the 3.01 as base version and the auto updater can't be used)? Does my CIV IV patch have any affect? It's the first (probably 1.00..?).

    Game works well will 3.01 patch. No problems with that one.
     
  3. ori

    ori Repair Guy Super Moderator

    Joined:
    Dec 17, 2005
    Messages:
    16,561
    Location:
    Baden-Württemberg, Germany
    ffh II is likely not compatible with the earlier patches (unless you have a very old version of it) so you need to install 3.17 to run. Civ4 is patched to 1.74 when you installed BtS - so that will not have any effect on your patch. And yes you should just download the patch and run it - it will take care of things :)

    Welcome to Civfanatics :)
     
  4. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    Thank you for answering but I need solutions!

    I have done exactly those things you said. Installed and patched to 3.17. BUT NOW THIS BtS DOESN'T EVEN START!

    How come a game as good as this can be done so badly that it doesn't even work.!? I have seen this problem facing many other comrades too.

    I actually don't even care to get FfH2 working but ATLEAST I want to play BtS.
     
  5. ori

    ori Repair Guy Super Moderator

    Joined:
    Dec 17, 2005
    Messages:
    16,561
    Location:
    Baden-Württemberg, Germany
    well that was not what you posted first ;)

    what happens when you try to start the game (not a mod like ffh - just BtS)?
     
  6. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    What comes is the little loader screen which disappeares when 'Init XML (uncacched)' comes. So nothing happens after that.

    As I mentioned version 3.01 works well.
     
  7. ori

    ori Repair Guy Super Moderator

    Joined:
    Dec 17, 2005
    Messages:
    16,561
    Location:
    Baden-Württemberg, Germany
  8. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    Xp.

    My computer isn't high end but runs CIV 4 very nice.
     
  9. ori

    ori Repair Guy Super Moderator

    Joined:
    Dec 17, 2005
    Messages:
    16,561
    Location:
    Baden-Württemberg, Germany
    could you please: try start the game - after that fails open windows event viewer and look for any error message that might be related to civ4 / bts

    http://support.microsoft.com/kb/308427
     
  10. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    It's in Finnish, but I translated parts of it..

    Virhesovellus civ4beyondsword.exe, version 3.0.0.91, module kernel32.dll, version 5.1.2600.5512, addres 0x00012aeb.

    Tell me if you aren't sure the meaning of something.
     
  11. exodys

    exodys Chieftain

    Joined:
    Sep 11, 2008
    Messages:
    15
    Bah! I can't believe how a major developer such as Firaxis can make things this sucky! This is like buying an optional AC devise in your car but it can not be used... F*cking make your buying customers happy..
     
  12. ori

    ori Repair Guy Super Moderator

    Joined:
    Dec 17, 2005
    Messages:
    16,561
    Location:
    Baden-Württemberg, Germany
    this game is not patched to 3.17 correctly. I fear a complete reinstall is the best way to start tackling this, follow the following stuff - if you do not have warlords ignore those parts:


    install the most recent version of DirectX 9c from Microsoft

    then do the following for a clean reinstall:

    Uninstall and Reinstall Civ4 Warlords BtS :

    Try to follow this order when doing stuff:
    Use Control panel to uninstall Beyond the Sword, then Warlords, then Civ4
    Delete "...\documents and settings\<username>\my documents\my games\sid meier's civilization 4" manually
    Delete "...\documents and settings\<username>\my documents\my games\warlords" manually
    Delete "...\documents and settings\<username>\my documents\my games\beyond the sword" manually
    Delete "...\documents and settings\<username>\application data\my games\sid meier's civilization 4" manually
    Delete "...\documents and settings\<username>\application data\my games\warlords" manually
    Delete "...\documents and settings\<username>\application data\my games\beyond the sword" manually
    Delete "...\documents and settings\<username>\local settings\application data\my games\sid meier's civilization 4" manually
    Delete "...\documents and settings\<username>\local settings\application data\my games\warlords" manually
    Delete "...\documents and settings\<username>\local settings\application data\my games\beyond the sword" manually
    (note: application data is a hidden directory so you need to configure windows explorer to show hidden files, also these directories in application data are sometimes removed by the uninstall routine)
    Delete "...\Program Files\InstallShield Installation Information\{CFBCE791-2D53-4FCE-B3FB-D6E01F4112E8}" (Civ4)
    Delete "...\Program Files\InstallShield Installation Information\{3E4B349F-10B5-4586-9D99-489A90A8B228}" (Warlords)
    Delete "...\Program Files\InstallShield Installation Information\{32E4F0D2-C135-475E-A841-1D59A0D22989}" (BtS)
    (note: InstallShield Installation Information is a hidden directory so you need to configure windows explorer to show hidden files).
    Install Civ4, immediately patch it to 1.61 (download it fresh from here)
    Install Warlords, immediately patch it to 2.08 (download it fresh from here)
    Install Beyond the Sword, immediately patch to 3.17 (download it fresh from here).
     

Share This Page