Cannot Get into City View or Move Units

Discussion in 'Civ2 - General Discussions' started by puglover, Sep 24, 2007.

  1. puglover

    puglover Disturber of Worldviews

    Joined:
    Nov 26, 2002
    Messages:
    9,643
    Location:
    Kansas
    I just bought Civ2 again and have been playing it a lot, just finishing the old WW2 scenario. :)

    However, I've run into a few odd problems. About half the time I start up the game, I can't open up the city screens by clicking on the cities, and thus I can't select any of the units in that cities. Also, the units will only move diagonally.

    What's weird is that sometimes the game works just fine without problems, other times it decides to annoy me. I'm running XP, but that doesn't seem to be the cause. What's going on?
     
  2. ElephantU

    ElephantU Deity

    Joined:
    Aug 19, 2002
    Messages:
    2,272
    Location:
    Phila PA
    The "clicking cities" problem in conjunction with the "units only move diagonally" problem sounds more like a problem with your mouse or keyboard drivers. Are you using a joystick or some other unusual pointer? Are you using a standard PC or a laptop with touchpad/eraserhead or something else? When you say "half the time", is that all in one continuous stretch or are there reboots and different profiles loaded at different times?

    BTW, there is a Technical Support forum that is a better choice for these kinds of issues...
     
  3. puglover

    puglover Disturber of Worldviews

    Joined:
    Nov 26, 2002
    Messages:
    9,643
    Location:
    Kansas
    No weird controllers. But I think you may be on to something with the identities. I'll try switching and see what happens.

    EDIT: Switching identities solved the problem. Thank you. :)
     
  4. Mercator

    Mercator Emperor

    Joined:
    Mar 9, 2001
    Messages:
    1,073
    :hmm: You're talking user accounts, right? What's the difference between the two? Is the one that works the admin account?
     

Share This Page