• Paradox Games has announced today their new game “Millennia”, a semi-historical turn-based 4X game. Find out more here .

Can't download the 1.17f patch!


Jan 29, 2002
Asmodeus's kitchen
I'm hoping some one can help me out - I'm trying to download the new patch from the standard : ftp://ftp.infogrames.net/patches/civ3/Civ3v117f.exe ftp site. However, using Download Accelerator I keep getting an error message that the 'File requested does not exist' and the download aborts. This is despite the fact that I could see that Download Accelerator has correctly identified the file and told me it gets an 'Excellent' connection.

What's going on here? Is there anywhere else I might try downloading it from. I also tried getting it from another computer that did not have a download accelerator installed and got the same message......
I tried to download the patch several times today and always got the dread "this page cannot be displayed" thingie. What could be causing this? Assuming Firaxis has not stopped distibution of the patch (for obvious reasons).
actually I was trying to download it from the CIV 3 site where it is advertised, I am downloading it as I write this from firaxis.com. My point is; why is not available from the CIV 3 site, where it belongs?
Top Bottom