Can't load save games


Mar 17, 2010
I love this mod but I can never seem to get any of these modded saves to load. I've tried going to the mod screen and applying the mods first before trying to load. I'm not using Steam Cloud save at all. Does anyone have any suggestions on what I can do to get around this? Clearly you all can't be having this problem.

I installed everything except the EUI mod, and the only other mod I am using is the Ingame Editor mod which is listed as compatible with this one in your doc. I have the latest version of Civ5 from Steam with all of the DLC, and the latest non-Beta version of this mod.

I luckily managed to get through 2 whole games just due to me not quitting the app at all, but I lost two interesting games partway through (the first when I voluntarily quit the game, and the second when Windows updated, grr).

Any help would be appreciated. Thanks!


Apr 5, 2016
make sure you load your saves through the mods menu (Mods -> Load Game)

loading through the main menu doesn't work for me either

Edit: ohh, nevermind. you already tried this.


Jul 14, 2015
There's currently an open discussion on Github concerning a similar problem. A gentleman in there seems to have found a workaround, if you're interested in that. Hopefully, a real solution will emerge in the future.

And, by the way, Github is the dedicated place for bug, crash, and general problem reports. Just a friendly notice to look around for similar problems and, if needed, post there next time. Registering there is easy, it's free to use, has a convenient search engine, fancy labels and all that good stuff. :)
Top Bottom