Can't update Civ 6

Destructoise

Chieftain
Joined
Jun 18, 2017
Messages
1
I've been trying to update Civ 6, cuz I REALLY wanna play Gaul. The update button goes blank for a couple seconds, then reappears, and no progress ever starts.

If any of you out there really love me, and want to help me play Gaul, please help me figure this shenanigan out. I just restarted my computer, still did not work :(.

Mac Os Mojave 10.14.6

Any Ideas?
 

gunnergoz

Cat Herder
Joined
Jul 16, 2002
Messages
2,307
Location
Southern California
I had 2 hours of problems with it. I ended up uninstalling Steam then re-installing it. Up until then I'd restarted my PC, and steam, over and over to no avai. The re-install worked but Steam was pretty slow doing it. I'm sure its a busy day for their servers.
 

Futumch

Calm as a Coma
Joined
Dec 27, 2001
Messages
754
Location
142 E 42 S
I had difficulty getting mine patched too. It did the updates but when I looked at the installed DLC the Gaul pack was missing. I ended up just giving up for the night and it was corrected this morning. I'm thinking it might have been something related to time zones as Steam often misreports time in things like the chat client.
After a small update it all worked anyway.
Disable all your custom stuff too (if you have any).
 

Bojevus

Chieftain
Joined
Apr 3, 2018
Messages
29
This appears to be a mammoth file size (11 gigs). Not sure why, but it's causing a lot of issues on my machine, though seems to be moving through the update now.
 
Top Bottom