1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ 4 maxing out GPU for no reason

Discussion in 'Civ4 - Technical Support' started by magicalsushi, May 10, 2020.

  1. magicalsushi

    magicalsushi Prince

    Joined:
    Aug 14, 2006
    Messages:
    573
    Location:
    Oxford, UK
    I had to retire my Windows 7 system this year, and bought a new Windows 10 PC; a fairly high spec one. I'm able to run BtS with the 3.19 patch. But...

    It maxes out my GPU. Constantly. Regardless of how high or how low I set the graphics settings in-game. The game runs smoothly regardless, but I'm concerned about the power I'm wasting and the unnecessary fan noise. By way of comparison, the GPU hovers around 70-80% usage when I run Portal Knights, a voxel MMO released 12 years after Civ 4.

    It's possible that I had same issue on my previous machine but never noticed - task manager didn't show me GPU usage in Win7, and the graphics card I was using didn't make noise. On both machines, the game maxes out one processor core while running (3.4GHz or the old machine, 3.8GHz on the new one).

    Is there anything I can do about this? The game clearly doesn't actually need all the processor power it's eating. I can live with the high CPU usage, but the ridiculous GPU usage bothers me.


    Windows 10 Pro 64-bit
    AMD Ryzen 9 3900X
    4GB AMD RADEON™ RX 550
     
  2. magicalsushi

    magicalsushi Prince

    Joined:
    Aug 14, 2006
    Messages:
    573
    Location:
    Oxford, UK
    I think I've managed to resolve this myself. I've set a custom performance profile for Civ 4 in the settings dashboard for my graphics card, and reduced the power cap down to the lowest possible level. It still shows 100% GPU usage, but I think that means it's using 100% of what is now a lower maximum speed, due to the power cap causing throttling. So, it's running cooler, using less power, and the fan doesn't come on. The game still plays fine.

    Edit: It's worth noting, I've probably voided the warranty on my graphics card by applying this manual setting, so keep that in mind if you consider trying this yourself.
     
    f1rpo likes this.
  3. Ramkhamhaeng

    Ramkhamhaeng Warlord

    Joined:
    Feb 24, 2014
    Messages:
    162
    Hello magicalsushi,

    you could also try to limit the frame rate in Civ4 itself:
    Edit SetMaxFrameRate = XX in {User}\My Games\Beyond the Sword\CivilizationIV.ini.

    But…
    Are you sure the game uses the graphic card? I assume you just got a very high cpu usage rate, but no GPU load.
    The 3D-redering is done in software rendering mode if the (old) DirectX version 9 is not installed correctly.
     

Share This Page