1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ IV requires Quicktime 6.0 or later???

Discussion in 'Civ4 - Macintosh' started by Leigh Louey-Gung, Jan 31, 2019.

  1. Leigh Louey-Gung

    Leigh Louey-Gung Chieftain

    Joined:
    Jan 31, 2019
    Messages:
    2
    Gender:
    Male
    Hi, I've just installed Civ IV (Steam) and am having a really frustrating issue. It downloads fine but every time I try to play it, it won't load and displays an error saying it 'Requires Quicktime 6.0 or later'. This doesn't make sense as I have Quicktime 7.x installed.

    Has anyone had encountered this before? And if so, is there a way around it?

    I've deleted and reinstalled the game and the error still comes up. I've also purchased it from the App Store and the same error appears. I've tried Aspyr support but they're a piece of ****. It took them nearly two months to respond to my initial support ticket and after requesting more information, have not responded.

    Anyone got a work around for this?

    I haven't played Civ since Civ 1 popped onto the scene and was super excited to play the one everyone says is the best, so this is frustrating as all hell.
     
  2. Leigh Louey-Gung

    Leigh Louey-Gung Chieftain

    Joined:
    Jan 31, 2019
    Messages:
    2
    Gender:
    Male
    Don't worry. Just upgraded to Mojave and it's now working!
     

Share This Page