1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ2 Problems with XP - can't find "Shell.dll"

Discussion in 'Civ2 - Technical Support' started by Gelli, Jul 1, 2004.

  1. Gelli

    Gelli Chieftain

    Joined:
    Jul 24, 2003
    Messages:
    5
    Location:
    New Hampshire, USA
    I just re-installed Civ2 after a long time of not having it, and now it decides to give me an error message...I click on the icon to start the program, and it says "Cannot find SHELL.DLL" several times, then a new window pops up, saying "Cannot find file C:\MPS\civ2.exe (or one of its components). Check to ensure the path and filename are corrent adn that all required libraries are available." I can only assume they mean the shell.dll...has anyone else encountered this error? Or know a way I might be able to fix it? Civ2 worked fine before on my PC, and I had WinXP Pro then, too and I believe the same hardware, we haven't changed anything for a while...please, I need help!! Thanks. :undecide:
     
  2. Mercator

    Mercator Chieftain

    Joined:
    Mar 9, 2001
    Messages:
    1,069
    You can get the file here:
    http://www.dll-files.com/dllindex/dll-files.shtml?shell

    My guess is that shell.dll is an old windows 3.1 era file that civ2 needs, and windows XP doesn't have it. I haven't heard about this error before though, so I'm not sure why you're getting it... Maybe the file got deleted when uninstalling some other old program.

    :hmm: Are you running civ2 in compatibility mode? Maybe that'll fix it (without having to get the shell.dll).
     
  3. Gelli

    Gelli Chieftain

    Joined:
    Jul 24, 2003
    Messages:
    5
    Location:
    New Hampshire, USA
    Thank you, Mercator, for offering that solution and I figured it would work...however I downloaded the file and placed it in the windows/system folder as the readme recommended, and Civ2 is still giving me that error...perhaps I should put the file into the Civ folder?? I don't know, I'm stumped as you are as to why I'm getting this problem...again, thanks for your help but it didn't work lol... :cry:
     
  4. Gelli

    Gelli Chieftain

    Joined:
    Jul 24, 2003
    Messages:
    5
    Location:
    New Hampshire, USA
    Yayy! It dawned on me after it didn't work the last time to try to move the file to the system32 folder rather than the system folder...and my Civ2 now works. Thanks Mercator! :D Apparently you shouldn't believe everything you see in a readme file...lol :lol:
     
  5. Mercator

    Mercator Chieftain

    Joined:
    Mar 9, 2001
    Messages:
    1,069
    Glad you solved it. :D

    And now you mention it, that does make sense. For Windows 9x the "system" folder is the um... system folder, but for Windows XP the "system32" folder is the default. I guess the readme was written with Win9x in mind.
     
  6. e-double

    e-double Chieftain

    Joined:
    Aug 3, 2004
    Messages:
    1
    Location:
    birmingham
    i now have the same problem with shell.dll can u help me?
     
  7. Mercator

    Mercator Chieftain

    Joined:
    Mar 9, 2001
    Messages:
    1,069
    Well, if the above didn't already help...
     
  8. Absinth minded

    Absinth minded Chieftain

    Joined:
    Aug 28, 2004
    Messages:
    2
    Location:
    Hässleholm, Sweden.
    I had the same problem, but when I did install the dll-file, it just says "civ.2 file damaged etc etc" when I try to open the game. Any more aces up your sleeves, Mercator?
     
  9. Absinth minded

    Absinth minded Chieftain

    Joined:
    Aug 28, 2004
    Messages:
    2
    Location:
    Hässleholm, Sweden.
    actually, it says that a "library" file has been damaged, whatever that means.
     
  10. C!pher

    C!pher Chieftain

    Joined:
    Aug 29, 2004
    Messages:
    1
    i am having the same problem sort of. when i try and launch the game it says Cannot Launch Civ2/civ2.exe. the file has been damaged. any help would be appreciated. if you could send me your exe file that might work?
     
  11. DeadlyLintRolle

    DeadlyLintRolle Chieftain

    Joined:
    Oct 18, 2004
    Messages:
    1
    I've gone through the entire list of problems mentioned here. Now I am to a point where I can start Civ2, but the second the program pops up i get the message

    CIV2 caused a general protection fault in module shell.dll at 0001:0095

    Choose close. CIV2 will close.

    And then it closes. I son't know what to do next. I downloaded the new shell file, I dropped it into the system32 folder. Can anyone please tell me what to do next?

    P.S. It's supposed to be DeadlyLintRoller
     
  12. ElephantU

    ElephantU Chieftain

    Joined:
    Aug 19, 2002
    Messages:
    2,272
    Location:
    Phila PA
    I assume you got the right SHELL.DLL for your OS. Now try re-installing Civ2 (and precede that with the Indeo video driver if you don't have that updated as well).
     
  13. Conrino

    Conrino Chieftain

    Joined:
    Dec 13, 2004
    Messages:
    104
    Location:
    Antlantis
    This says I have to buy these files! I am indignant!
     
  14. CS3

    CS3 Chieftain

    Joined:
    Dec 26, 2004
    Messages:
    1
    Hello!

    Thank you for all your help with this problem but...

    Everytime I restart my computer I have to reinstall those shell files. Does anyone know why?

    Thanks!
    Lindsay
     

Share This Page