1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ2 ToT 1.1 patch doesn't seem to install properly

Discussion in 'Civ2 - Technical Support' started by Risewild, Oct 4, 2016.

  1. Risewild

    Risewild Chieftain

    Joined:
    Jan 13, 2014
    Messages:
    6
    Hello Civ fanatics.
    I have been pulling my hair for 2 days now with a problem that I can't seem to find anything about it online.

    I installed the Civilization 2 Test of Time English version game on my Win 7 64 and all went well. I could start the game and no crashes I could experience (although I just started a game and didn't really play).

    Then I installed the English version 1.1 patch (using the run as Admin option). It seemed to have installed properly. Started a game and it still works.

    Then I noticed that the blurry and dark graphics hurt my eyes (I have problems with blurry graphics due to some eye sight issues), so I searched the internet for a graphic overhaul and found a very nice one made/compiled by the user Catfish.
    I got that overhaul and read the instructions. It requires The Test Of Time Patch Project.

    I downloaded the Patch Project latest version (v0.14.1) and put it in my game's main directory (like the instructions say), I then run it (using the run as Admin option) and in it's window it shows in red boxes that my Civ2.exe is version "TOT v1.0" and it is "NOT PATCHED".

    I thought it was weird so I run the ToT 1.1 patcher again, installed it again and tried the TOTPP again. Without any surprise it still said I had the v1.0.

    I downloaded the ToT 1.1 patch from 2 other different sites and the result was the same.
    I tried to remove all of the game files from it's directory and just keep the civ2.exe there and run the patch again to see if it was extracting/patching the files in the right directory and indeed it created all the patched files in the now empty directory (well not empty, it contained the civ2.exe).

    I tried reinstalling the game and run the patches, but the result was the same. I tried searching this problem but no one seems to have it because I couldn't find it mentioned anywhere (and this is the third day I have been searching online for similar problems).

    I think that the 1.1 patch is not doing anything to my Civ2.exe because the .exe doesn't change size at all (but the rest of the patch files seem to update).

    As a last resource I tried to add manually the registry information on where my game is installed and still didn't work.

    Today out of desperation I went so far as to download a nocd crack to see if it would change the exe in some way to make the TOTPP detect it or something (yeah, I am running out of ideas) and the nocd crack/patch needs the 1.1 civ2.exe and it says the exe is not the correct (just like TOTPP does) so it is another thing telling me that my civ2.exe is not patched to 1.1.
    To finish I got an already patched no-cd civ2.exe and TOTPP says it is an unknown version. So it is actually detecting the exe properly, for some reason the 1.1 patch doesn't seem to change my civ2.exe.

    Notes: I have administrative rights, I checked to see if the civ2.exe was "read only" but it wasn't, I tried a different hacked exe and TOTPP detected it was a different exe, I tried running the 1.1 patch several times and downloaded it from 3 different sites, made sure the game language and patch language were both the same (english), reinstalled the game a few times, made sure the registry entries point in the right directory and tried running a nocd patch and that also said my exe is not 1.1...

    I run out of ideas and no internet search came close to show me someone else with this problem. So here I am, asking the most knowledgeable people in terms of Civ games from the first to the last :).

    So anyone knows what is happening and if there is anything I can do to fix this problem?

    Thanks for your time and sorry for the wall of text though... :(
     
    Last edited: Oct 4, 2016
  2. JCountry

    JCountry Chieftain

    Joined:
    Sep 16, 2018
    Messages:
    1
    I had the same problem, the solution is simple. It is your antivirus, it is interfering with the patch. Turn it off, run the patch, then turn the antivirus back on.
     

Share This Page