1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Civilopedia bugs (minor)

Discussion in 'Civ4 - Unofficial Patches' started by PieceOfMind, Jun 25, 2009.

  1. PieceOfMind

    PieceOfMind Drill IV Defender Retired Moderator

    Joined:
    Jan 15, 2006
    Messages:
    9,312
    Location:
    Australia
    This is a very minor bug but I thought I'd best mention it anyway. It appeared with 3.19 as far as I can tell.

    Under the civpedia entries for Harbour and for Cothon, it says they are required to build a Feitoria - not a Customs House. The Feitoria is the Portugese UB. I checked in 3.17 and there it said Customs House correctly.

    I'm wondering why on Earth a change in 3.19 would have caused this. If I see any more civilopedia bugs I'll post them here.

    EDIT... It seems I can't reproduce it now. Either it's a bit elusive or I was mistaken in the first place. Hmmm
     
  2. BwdYeti

    BwdYeti Chieftain

    Joined:
    Jun 17, 2008
    Messages:
    11
    It's likely you were just Portugal and ingame. If your UB has a prerequisite it will say the UB's name instead of the regular building in the Civilopedia. At least I think it does.
     
  3. PieceOfMind

    PieceOfMind Drill IV Defender Retired Moderator

    Joined:
    Jan 15, 2006
    Messages:
    9,312
    Location:
    Australia
    I thought that too, but turns out I was playing as the French. I did have Unrestricted Leaders on for memory, if that matters.

    My first thought when I saw the typo was to check whether I was Portugal.
     
  4. phungus420

    phungus420 Chieftain

    Joined:
    Mar 1, 2003
    Messages:
    6,296
    I've seen this before as well, and I'm talking about the opening screen civilopedia. Not just the feitoria, but the citadel as well. It's totally random though, I don't know how to reproduce it. And there are no python exceptions or assert messages when this happens. One thing though, I've only seen it in the sevopedia, but that's more likely because I never play default civ with the default civilopedia...
     

Share This Page