1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Civilopedia building entries

Discussion in 'Civ3 - Creation & Customization' started by Takfloyd, Jun 14, 2005.

  1. Takfloyd

    Takfloyd Chieftain

    Joined:
    Apr 17, 2005
    Messages:
    197
    Location:
    Bergen
    In the Conquests editor(Perhaps in the regular one too)
    you select the Civilopedia entry for buildings from a drop-down list.
    How do you add on entries there? I put in new entries in the Civilopedia text
    file, and also in the pediaicons file(Just in case), but they don' t show up
    in the editor. I think there' s some prebuilt list in there, for whwn I erased whole entries from the text file, they were still listed in the drop-down list.
    Do I just have to edit existing entries, or is there a way to add on more?
    Help!
     
  2. Varlin Saliptor

    Varlin Saliptor Does not hate the future.

    Joined:
    Oct 8, 2004
    Messages:
    1,515
    Location:
    San Marcos, Texas
    That is a Conquests only thing. I have not yet tried to add buildings to my mod yet, but I know what you are talking about. I know there is a way around it, but i can't remember it right now.
     
  3. Willem

    Willem Chieftain

    Joined:
    Feb 12, 2002
    Messages:
    7,313
    Location:
    Canada
    Did you reload your editor after adding the entries? It won't automatically update itself, you have to restart it. It should work by adding an entry in the appropriate area of the pediaicons if you do that.
     
  4. Plotinus

    Plotinus Philosopher Administrator

    Joined:
    Nov 14, 2003
    Messages:
    16,651
    Location:
    Cornwall
    Putting new entries in the PediaIcons file is the way to do it. Since you say you've done that I'm not sure what the problem can be, but it's something to do with that. Maybe you've not used the right format - BLDG_Thing - or perhaps you just didn't save the altered file (I forget to do that all the time).

    As for why the ways of entering entries and icons is completely different for buildings and units - that's just one of the great mysteries of life!
     

Share This Page