Classic ERA problem with Archer AI


Aug 13, 2012
I love to play long heavily modded games in different ERA's. My newest game is set in Classic, ending the ERA progression there and with a lot of modded civilizations that work well in Classic ERA.

Archers and Chariot Archers become too powerful in such games, not so much because of their shooting power, but the problematic part is the range. So I changed the range from 2 to 1 for all archer units.
Sadly the AI cannot seem to make the archer units work with this change. The archer units move around the map, but almost never attack anything except cities.

Hopeful solution:
Can anyone give me an idea to how I can make the AI work with ranged units that has only 1 range? I know there must be something out there in the code as Gatling Guns works fine in a normal game.
I am also up for other suggestions if there's some good solutions out there.

Before you answer:
I have tried using the Smart AI mod that should make it possible for ranged units to move and attack on the same turn. This still does not change how the units behave sadly, which I found rather weird.
I have tried playing Anno Domini mod and sadly it is not what I am looking for.
I have considered lowering movement of the ranged units, but sadly that would ruin the idea behind the Chariot Archer. I'm leaning towards this solution though if no one else can help me with a proper solution.

Thank you very much for your time, hoping someone can help me.
Top Bottom