• Civilization 7 has been announced. For more info please check the forum here .

[C3C] Color palette glitches

md4

Warlord
Joined
May 2, 2020
Messages
132
I'm not liking my chances on this one, but as of tonight (after 1–2 months without issue) I am getting constant color palette glitching like so:

See the bottom-right summary panel:


Behold many icons (most notably under Masonry, Pottery, Construction):


Of note, the icons change periodically, see the following short video capture: https://i.imgur.com/kIBA9e8.mp4 (apologies for the odd cropping of the video, wasn't intentional but there's enough to illustrate the point)

Things I have tried
  1. Full re-install. (This includes full removal of the install folder, as well as cleaning registry keys containing "Civilization", "GOG" and "Firaxis".
  2. Rebuilt the VM from scratch, completely clean install of C3C.
I even reinstalled to a different path in case it made any difference ("C:\GOG Games\C3C" just in case anything might try to reference a cached version of an old file).

My Setup

I am running the GOG install of Civilization 3 Complete using a Windows XP SP3 virtual machine, running on VirtualBox. The host OS is Windows 7 Professional. Hardware is a fairly ancient HP ProBook 4520s.

I'm perplexed because, while it might seem like an odd setup it's been working fine for quite some time already, and there isn't really anything that can change on an isolated VM (no NIC) with no other software installed, since its only purpose is to play Civ3.
 
Last edited:
md4, I don´t have this problems yet, but when remembering well, more than one decade ago, I had similar problems triggered by my graphics card. At that time the program was running better with an ATI than a Nvidia card. Can it be, that your problems are triggered by an update of the driver of your graphics card?
 
I checked, and the driver date is from 2011, so I'm guessing not. I wouldn't think updates of any kind are likely, given I am running an out-of-support OS (Windows 7) on a decade-old laptop.

I built a new VM from scratch to no avail, I can't see that VirtualBox has auto-updated recently either, so the only remaining possibility seems to be some other state change on my host machine. It seems the only viable course of action is a full re-install but I just can't justify the interruption to everything else I do for just one game so I'm seriously considering just putting up with the problem. It sucks, but by all measurements I've got my money's worth from Civ3 many times over.

Either that or I install it on the host OS and put up with the severe lag and constant "too many hyperlinks" error popups that drove me to an virtual XP machine in the first place. So at least I have options.
 
Either that or I install it on the host OS and put up with the severe lag and constant "too many hyperlinks" error popups that drove me to an virtual XP machine in the first place. So at least I have options.

The message "too many hyperlinks" triggered by needed resources from units and buildings can be avoided, when letting the first of the resource boxes empty. In that case you will see no resource needed for the unit/building at all, so you should write a note about the resources as a prerequisite in the civiliopedia text of that unit/building.


 

Attachments

  • Hyperlink Bug1.jpg
    Hyperlink Bug1.jpg
    233.8 KB · Views: 294
  • Hyperlink Bug2.jpg
    Hyperlink Bug2.jpg
    233.2 KB · Views: 286
Last edited:
  • Like
Reactions: md4
*rolls up sleeves, and opens Civ3ConquestsEdit.exe*
 
So apparently what fixed it was rebooting a bunch of times.
 
This has returned to plague me again. I have discovered since that this is something to do with the host OS (tl;dr—I run Civ3 from a Windows XP virtual machine on VirtualBox), as this problem occasionally returns after rebooting the host. Normally I reboot a 2nd time and it's good to go, however that rather unscientific trick is no longer working for me and the colour glitching looks like it's here to stay now.

To reiterate, my laptop is over 10 years old, my host OS is Windows 7 Pro, so no new updates there. I haven't updated VirtualBox either. I honestly have no idea what precarious state is so affected by simply rebooting. I have no 3rd party security software (just MS Security Essentials), and I'm at my wit's end.
 
Top Bottom