1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Communitas on linux

Discussion in 'Communitas Expansion Pack' started by gfurst, Jul 2, 2014.

  1. gfurst

    gfurst Warlord

    Joined:
    Sep 4, 2010
    Messages:
    202
    Location:
    Beag√°, MG, Brasil
    Has anyone tried and worked this?
    Well I have, and it seems the Ui gets broken, map generated correctly but, in game windows appear missing, can't move unit and other caveats.
    Basically makes the game unplayable.

    Similar experience with these guys.

    Anyway, just wondering if you guys are aware of this, and if may be fixable.
     
  2. ExpiredReign

    ExpiredReign Deity

    Joined:
    Jan 3, 2013
    Messages:
    2,450
    Gender:
    Male
    Location:
    Tasmania
    It looks like you may be on your own with this.

    I notice from your other postings you are using the new linux port of the game engine. That immediately nerfs my first suggestion as I was going to ask how your 'WINE' setup is.

    Since it comes down to the file-system differences, case-sensitive or not, the only resort I think you have is to do a project wide find/replace and convert all the files to lowercase. However I have no idea what that might do to the functionality of the lua.

    Sorry, wish I could be of more help.:(
     
  3. Caelo

    Caelo Chieftain

    Joined:
    Jul 6, 2014
    Messages:
    1
    It is indeed just a case-sensitivity problem. Follow the these instructions (from http://steamcommunity.com/app/8930/discussions/0/540744299996631016/)

    ciopfs is basically a userspace case insensitive filesystem and will probably fix about 90% of the problems with mods on linux.

    I've added the above link to the reddit page as well...
     
  4. thehug0naut

    thehug0naut Chieftain

    Joined:
    Jan 26, 2015
    Messages:
    1
    I followed the ciopfs method above using the files downloaded from Steam. Despite loading up ok initially the AI & Tools Mod was giving me random crashes.

    Thought people would like to know that the classic branch of the mod (link below) works swimmingly :D (Well for my use which is AI & Tools with CepMap)

    https://github.com/Thalassicus/cep-bnw/tree/classic

    Unfortunately you have to have access to a windows PC to build the package before you can install them properly on linux. I'm happy to supply my version of the package file to those who operate a Windoze free existence.
     
  5. Saraphim

    Saraphim Chieftain

    Joined:
    Jul 20, 2015
    Messages:
    1
    That would be very kind of you! I've had no luck making the steam version work, and have no Windows to try this out with.

    Out of curiosity: Has anyone actually tried reporting the bugs with the Linux version, or is there some fundamental limitation that makes this a moot exercise?
     

Share This Page