Crash - possibly MSVCP90.dll

HahnHolio

Warlord
Joined
May 15, 2004
Messages
138
Location
Germany
Hi all!

I just checked my eventvwr after the 3rd crash at the same point in the game and always this: MSVCP90.dll, Version: 9.0.30729.4926
Module failed to work ...

The crash occurs at the end of turn 217 ... nothing special build, but my first war ended
in a peace treaty on the last turn?!
Maybe thats gotta do something with it?

If anyone encounters likewise behavior, please post here and we might find the sorce to
these crashes!

Greetz

HahnHolio

P.S.: I am not much of a programmer, but someone here might find a solution, i hope!
P.P.S: yes, i have the most recent Drivers and repaired/updated the VisualC files with the recent installation ... Game runs fine and smooth in DX11 ^^
 

spmoura

Chieftain
Joined
Oct 11, 2010
Messages
1
Same problem here, but in my case the MSVCP90.dll file version is 9.0.30729.4148 and the crash occuring during a turn 488 and nothing special was happening either. I played other games and they went just fine all the way whit no glitches, except this one.

Hope there is a solution for this.
 

gkgk99

Chieftain
Joined
Jul 5, 2012
Messages
4
Anyone having a problem with games crashing playing civ 5 G&K involving MSVCP90.dll and the civ*.exe file? The game freezes, with cursor movement, and I have to ctrl+alt+del to end the task. Windows is encountering an error and the program must be closed. If I lower graphics settings, update everything the exact same turn crashes if I load the game again. I have well over the recommended system requirements and this is perplexing me. Anyone have an idea or solution? I tried some of the fixes for the MSVCP90.dll problems from before the G&K expansion. I reinstalled the game verified system files and even reinstalled the Visual C++ pack.

Tech support was no help, they sent me to another company that has nothing to do with the game, and then to Microsoft; both, no help. The game worked fine before the G&K expansion pack.

Help?
 

The_J

Say No 2 Net Validations
Administrator
Supporter
Joined
Oct 22, 2008
Messages
37,454
Location
DE/NL/FR

Moderator Action: Threads + posts merged.

It's probably a game related bug, which brings the engine to barf :dunno:.
If it's repeatable, then you might want to attach the savegame, so that the devs could possibly have a look at it, but else...:dunno:
 

Adjuvant

Emperor
Joined
Jul 23, 2011
Messages
1,474
Are you using a mod? I'm getting kinda the same crash lately when I playtest an Israel mod.

Here are my details of the crash.

Spoiler :
Problem signature:
Problem Event Name: APPCRASH
Application Name: CivilizationV_DX11.exe
Application Version: 1.0.1.705
Application Timestamp: 4febeef5
Fault Module Name: MSVCP90.dll
Fault Module Version: 9.0.30729.6161
Fault Module Timestamp: 4dace5bd
Exception Code: c0000005
Exception Offset: 0000506e
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


I play some Civ5 almost every day and only have crashed when using this mod.
 

Adjuvant

Emperor
Joined
Jul 23, 2011
Messages
1,474
No answers from the people experiencing crashes of this type on mod use?
 

ragan651

High Regent of Candlewick
Joined
Jul 9, 2012
Messages
328
Location
NW US
I found a similar problem involving MSVCR90.dll crashing (not MSVCP90.DLL) in Civ V on the Steam forums. The solution was to run a command prompt as administrator, then enter sfc /scannow

This basically scans certain system files for errors and re-registers them if necessary. It can take while, though.
 

gkgk99

Chieftain
Joined
Jul 5, 2012
Messages
4
Thank you, I already tried that with no results. I finally found someone with the tech support who would help, but he mentioned that it just may be a problem with the game that has not been corrected or an incompatibility with the specific make and model to the video card.

So I guess I am still S.O.L. until they release another patch…….. Unless someone has any other ideas?

(My video card ASUS NVIDIA GTX 560ti 1024mb)
 

timtofly

One Day
Joined
Sep 28, 2009
Messages
9,445
Thank you, I already tried that with no results. I finally found someone with the tech support who would help, but he mentioned that it just may be a problem with the game that has not been corrected or an incompatibility with the specific make and model to the video card.

So I guess I am still S.O.L. until they release another patch…….. Unless someone has any other ideas?

(My video card ASUS NVIDIA GTX 560ti 1024mb)

Have you tried to delete your Nvidia driver and install a different version?
 

gkgk99

Chieftain
Joined
Jul 5, 2012
Messages
4
I have tried many things the tech support mentioned. From editing the game files and disabling components to reinstalling Visual C++ 2008. This includes installing new drivers for sound, video and other controllers. I even tried the latest beta driver from NVIDIA (always clean install).

It is a strange crash though, no matter what I do, every time a specific turn is reached the game locks up. One new game might be turn 200 another might be 180… and so on. This happens every time that specific game is loaded as well. This is only after installing G&K, never before. Nothing else changed on the computer except the G&K expansion.

There are two things that I have not tried, and not looking forward to. These are a last resort to eliminate the possibility that the problem is not completely with my computer. One would to try another video card, which I don’t have. Another would to completely wipe my computer clean and install a fresh OS.
 

tahumom

Chieftain
Joined
Aug 13, 2009
Messages
2
Same symptoms, I have NVIDIA GeForce GT 540M. Very disconcerting. I've tried in DX9 and DX11 with crashes in both cases.



Spoiler :
Problem signature:
Problem Event Name: APPCRASH
Application Name: CivilizationV_DX11.exe
pplication Version: 1.0.1.705
Application Timestamp: 4febeef5
Fault Module Name: MSVCP90.dll
Fault Module Version: 9.0.30729.6161
Fault Module Timestamp: 4dace5bd
Exception Code: c0000005
Exception Offset: 0000506e O
S Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
 

Torvald

Prince
Joined
Oct 4, 2010
Messages
309
Location
San Antonio, TX, USA
Nvidia just released v306.23 of their graphics card driver.

It is WHQL certified, so should be stable to use.

You might want to try installing it and see if it helps with your crashing problem.
 

TryA

Chieftain
Joined
Mar 29, 2013
Messages
1
Hi everybody who have this problem!

Just turn in-game video option "Leader Scene Quality" to "Minimum"! It works! ;)
 

goozer321

Chieftain
Joined
Apr 3, 2013
Messages
2
Agree with TryA

I think the crashes are caused on certain turns, when there are lots of units, when a AI Civ initiates a conversation during their turn, which is why it happens at different certain turns for different games, but always the same turn in a given game.

I put mine down to "Low" several weeks ago and haven't had a crash since.

:crazyeye:
 
Top Bottom