Disappearing Mods

Discussion in 'Civ5 - General Discussions' started by shaglio, Jan 2, 2013.

  1. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    I’m not sure is this belongs in the Creation & Customization section (even though it’s not about any specific mod, but how the mods act) or in the General Discussions section (even though I’m not discussion generals at all), but here’s my situation:

    Lately I’ve been having a problem with mods disappearing. I’ll start a game with InfoAddict and 5 of WHoward’s mods, play for a bit, and then save my game and log out. The next day when I go to the Load screen, if I click on “MODS” on the bottom right of the leader picture, I notice that InfoAddict and only 3 or 4 of WHoward’s mods are listed. After enough times saving and loading my game, eventually all I have left is InfoAddict (all the other mods are gone from my saved game).

    Is this a previously documented glitch with mods and I’ve just never noticed it before because I usually only play with one mod at a time? Is it because WHoward’s mods are no longer on the Steam Workshop? Should I just chalk it up to “Mods act unpredictably?” Can anybody offer any insight for me?
     
  2. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    So, I guess nobody else has had this problem?
     
  3. tni

    tni Chieftain

    Joined:
    Jan 3, 2013
    Messages:
    3
    You have to go through the 'Mods'/'Single Player'/'Load Game' each time. Otherwise, you lose some mods. Don't ask me why they screwed up things this way...
     
  4. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    Huh, I’ll have to give that a shot. I usually just go through the main load game screen and haven’t had a problem before, but I’m sure things change. It’s worth at least trying. Thanks for the suggestion.
     
  5. Dig-Doug

    Dig-Doug Savant of Sutpidity

    Joined:
    Jul 16, 2009
    Messages:
    198
    Location:
    Monroe WA
  6. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    Unfortunately, this didn't work for me; the mods still disappeared.

    Perhaps a Moderator could move this thread to "Creation & Customization" or "Tech Support" please?
     
  7. Dig-Doug

    Dig-Doug Savant of Sutpidity

    Joined:
    Jul 16, 2009
    Messages:
    198
    Location:
    Monroe WA
    Did you even read what I was telling you?!? You have to install them separately then use them as usual because WHoward removed them from the steam vault, so they can't be installed automatically. It works for everyone else
     
  8. MisterBoomBoom

    MisterBoomBoom King

    Joined:
    Nov 10, 2010
    Messages:
    699
    Hmmm...I had some mods vanish from my active list of an ongoing game. I obviously could not load the game because of the missing mod. This is still a problem.
     
  9. Dig-Doug

    Dig-Doug Savant of Sutpidity

    Joined:
    Jul 16, 2009
    Messages:
    198
    Location:
    Monroe WA
    Have you downloaded the mods and installed them according to WHoward's inst? Then run through the MODS section to load them again?

    There really isn't much to this after you have the mods installed. Just be sure the mods are in the proper directory in order to load. Then, in-game check each one you want to load that were already in the game you started. If you still have mods you need that were not loaded by WHoward then you'll need to reget those either with the in-game mods steam controls(if available) or by downloading as with WHoward's mods.

    Other than that I would not know what to do since it worked for me at that point.
     
  10. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    Yes, I read what you said. I downloaded WHoward's mods from his site and not from Steam.
     
  11. Dig-Doug

    Dig-Doug Savant of Sutpidity

    Joined:
    Jul 16, 2009
    Messages:
    198
    Location:
    Monroe WA
    and your still having problems with installing them:confused: That's kinda weird, What is the exact problem? Mods are supposed to install from steam but WHoward took his mods off steam permanently, therefore they have to be downloaded from here at CFC.
    Secondly, when running the mods after installation do you see them where mods can be selected for running each game you start? If so just select them and play, if not then they are not in the correct directory and you'll have to go back to make sure they are.

    After that just load through mods each start of the game since Steam has elected to stop people from loading them without going through the process of mods/single player.;) (I believe this is an attempt at stopping people from having so many load issues, or that it stops people from having cracked versions of the game with mod use:mischief:).
     
  12. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    I downloaded the mods from his website directly into the mods folder for Civ 5.

    When I click on "MODS" in the main menu (and agree to the terms) I see all of the mods listed. I check the green circles to the right of the mods I want to use, click "Next", and start a new game. I play for a while and then save the game before I go to bed. The next day, when I go to reload my saved game, some of the mods are no longer listed in the save (I single-click on the save game file and click on "MODS" on the bottom right corner of the leader's picture). After reloading my game enough times, eventually InfoAddict is the only mod left and all the WHoward mods are gone (which leads me to believe it might be an issue specifically with his mods, but I know very little about creating mods).

    I've tried loading my game both from the main menu and through the MODS menu, but they still disappear either way I do it. If memory serves me correctly, from reading WHoward's post about why he took his mods off of steam, I got the impression that he was upset by users complaining about them. Perhaps this was what they were complaining about (I didn't stumble upon that thread until after the fact and didn't feel like reading hundreds of old posts)? I guess I'll just have to play without his mods (or go back to using CivUP, since most of the ones I used are also in there).
     
  13. Dig-Doug

    Dig-Doug Savant of Sutpidity

    Joined:
    Jul 16, 2009
    Messages:
    198
    Location:
    Monroe WA
    From what you've said here I'd say you have something wrong with game files that are directly related to mod loading specifics. Doesn't make sense that they should "unload" every time.

    I don't do modding myself and so here is where the Moderators should put this thread into the mod section for further help. You can also check out the 2k threads section on this topic. Here's one I happen to have still: http://forums.2kgames.com/showthread.php?191151-Mods-dissapearing

    Then write 2k also and see if they can tell you something else. The new guy there that took over 2k gregs position recently is pretty up to beat on things and is eagerly helping people.

    Sorry I can't figure this out further it's just above all my experiences with this.:D
     
  14. shaglio

    shaglio The Prince of Dorkness

    Joined:
    Jun 15, 2001
    Messages:
    3,562
    Gender:
    Male
    Location:
    Lawrence, MA, USA
    Thanks for your help, anyway. I appreciate it a lot.
     
  15. ignite

    ignite Chieftain

    Joined:
    Sep 26, 2010
    Messages:
    62
    Location:
    Minnesota
    I've had mods deleted from my mod folder, but these were mods I subscribed to on steam. I altered them and subsequently unsubscribed from them to prevent Steam from reverting my changes, but Steam instead simply deleted the mods that I unsubscribed from. I use many of WHoward's UI enhancement mods though and I haven't had any of them disappear.
     

Share This Page