1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Downgrade MGE to Classic

Discussion in 'Civ2 - Technical Support' started by Jokemaster, Nov 22, 2010.

  1. Jokemaster

    Jokemaster Insert something here

    Joined:
    Nov 15, 2010
    Messages:
    524
    Hello all...

    So I recently tried to downgrade my copy of MGE to 2.42 using this patch:
    http://forums.civfanatics.com/downloads.php?do=file&id=58

    I unzipped 2 other files provided by Prof. Garfield on this post:
    http://forums.civfanatics.com/showpost.php?p=9389471&postcount=11

    and got the missing DLL's the original patch did not provide.

    All, but one. WinG.DLL (a DLL that is needed to play some old games... needed in 2.42 and FW but not in MGE) was missing. So I went and downloaded it from here:
    http://www.dll-files.com/dllindex/dll-files.shtml?wing

    unzipped the file, copied to the System32 directory, now I was thinking it was over. I launched the Classic Civ (XP compability mode turned on) I got to the ''choose language'' window, and to the animated heralds window (chose ''Yes'') Now Civ starts launching, and suddenly, a NTVDM.EXE error popped up saying it stopped working and will close. Now I can't run Classic Civ2 without getting that error that causes Civ to close (I can still run MGE however)

    I know that NTVDM.EXE is a generic process that aims to provide support for 16-bit apps (2.42 is one of them I think) I'm not sure if MGE is a 16-bit app too, but I am not very pleased with that...

    So can anyone help me?

    Oh... before I forget...
    I have Vista 32-bit Home Premium. No other patches were ever applied on any copy of Civ2 I have.
     
  2. Jokemaster

    Jokemaster Insert something here

    Joined:
    Nov 15, 2010
    Messages:
    524
    THREAD CLOSED: It now works!

    Turns out trying to run Civ2 2.42 with the MGE CD made NTVDM.EXE crash... I now run 2.42 without the CD in XP compatibility mode, and everything is OK (well, except the music/advisors because of the lack of CD. And also the Goto command probably (haven't tested that one yet... but what else could we expect? ;)
     
  3. Prof. Garfield

    Prof. Garfield Chieftain Supporter

    Joined:
    Mar 6, 2004
    Messages:
    2,034
    Location:
    Ontario
    I recommend this be renamed something along the lines of "Downgrade MGE to Classic" and stickied. This is a concise post to describe how to downgrade to classic, so hopefully people will look here for info.
     
  4. Magic_gorter

    Magic_gorter Moderator Moderator Civ2 GOTM Staff

    Joined:
    Apr 6, 2006
    Messages:
    2,699
    Location:
    Amersfoort (Netherlands)
    Moderator Action: Changed and stickied
     
  5. starlifter

    starlifter Chieftain

    Joined:
    Jun 17, 2001
    Messages:
    4,212
    Civ 2 2.42 will not run in native x64 environments.

    As a note for those that arrive here by Googling, if you have Civ 2 versions before MGE (plain vanilla, FW), you must "upgrade" to MGE with Cedric Greene's patch, or else run a 32-bit environment with x64.

    :)
     
  6. darbyjack

    darbyjack Chieftain

    Joined:
    Feb 10, 2007
    Messages:
    17
    Is this really a downgrade? I tried it today and some aspects still seem different.

    For example, in classic Civ 2, the Great Wall would act as city walls in all of your cities. That is not the case after installing this patch.
     

Share This Page