1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Either horrible performance or bugged animation (win10)

Discussion in 'Civ3 - Technical Support' started by Hirmuolio, Feb 22, 2017.

  1. Hirmuolio

    Hirmuolio Chieftain

    Joined:
    Jun 3, 2014
    Messages:
    6
    If I run civ III normally (not in compatibility mode) the game freezez for the duration of unit death animation but otherwise runs normally with good performance. Happens in nonsteam and steam version.

    If I run the game in compatibility mode (XP or abve) the game doesn't freeze during unit death but the performance is ruined.
    With nonsteam version the game uses all the CPU power it can get and is unplayable when there are moderate ammount of units on map.
    With steam version the game run better but still pretty badly.

    Starting new game has good/decent performance. It seems like worst performance drop only happens when a save is loaded. I tested with the "age of discovery" scenario and the game ran ok but not too well when I start the scenario. But if I save and load it the game is completely unplayable. If I load the game without compatibility mode performance is perfect.

    OS: Windows 10
    GPU: RX 480
    CPU: i5-3570K


    EDIT:
    After some testing the game freezes during unit death if task manager is open. If I close task manager the animation plays properly. Perhaps some other programs cause it too if they are running on background.
     
    Last edited: Feb 28, 2017

Share This Page