1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Endless starting bluescreen

Discussion in 'Civ6 - Technical Support' started by MorGalad, Oct 22, 2017.

Thread Status:
Not open for further replies.
  1. MorGalad

    MorGalad Chieftain

    Joined:
    Oct 24, 2016
    Messages:
    8
    Gender:
    Male
    Hi, guys. It's been a while since I last played Civ 6. Yesterday I downloaded it again from my steam but when i tried to create a game all I got was a blue screen that just stayed there forever. I've attached a picture to this post so you can see what I mean. Do you know why it happens like that?

    Furthermore, everything in the menus seems really slower than before. I managed to load a very old game of mine but when i tried to exit back to main menu everything crashed and I needed to sign out of windows. ctrl+alt+ del wasn't functional.
     

    Attached Files:

    • civs.jpg
      civs.jpg
      File size:
      740.5 KB
      Views:
      42
    Last edited: Oct 22, 2017
  2. MorGalad

    MorGalad Chieftain

    Joined:
    Oct 24, 2016
    Messages:
    8
    Gender:
    Male
    I think the modes were the culprit. I removed them all and now everything works fine.
     
Thread Status:
Not open for further replies.

Share This Page

Ebates: Get Paid to Shop