Error starting Asset Editor

Odofakyodo

Chieftain
Joined
Aug 3, 2021
Messages
10
Hello all,

Hopefully a easy question someone will be able to answer. I am trying to open the asset editor but I get a dialog box with the following error:
Code:
---------------------------
Civilization VI ModBuddy
---------------------------
Could not find a part of the path 'C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization VI SDK\ModBuddy\Civ6\DLC\Expansion2\pantry\Expansion2.Art.xml'.
---------------------------
OK   
---------------------------
I'm a bit stumped as to what the problem here is. I can't find anything in my mod files that references Expansion2.Art.xml. I notice that if I change the name of my own Foo.Art.xml file to something else so it does not match the mod name then it complains that it can't find "Foo.Art.xml". But when the name of the file does match the mod name then it complains about "Expansion2.Art.xml". My mod does depend on Gathering Storm content, so do I need to copy a file from the Expansion2 DLC to somewhere in my mod?

Any help would be greatly appreciated!
 

Odofakyodo

Chieftain
Joined
Aug 3, 2021
Messages
10
More observations:

In the IconXML section of the documentation (file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Sid%20Meier's%20Civilization%20VI%20SDK/Documentation/Civ6Docs.html#IconXML) there are references to "Project Builder" and "Game Art Specification". It sounds like the latter references the *.Art.xml files. It also says the following:

For the base game this is in $\Civ6\pantry\Civ6.Art.xml

For XP1 this is in $\Civ6\DLC\Expansion1\pantry\Expansion1.Art.xml

For XP2 this is in $\Civ6\DLC\Expansion2\pantry\Expansion2.Art.xml

I see that the folder C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization VI SDK\ModBuddy\Civ6\ does not exist on my machine. Am I supposed to have files there? Do I have a bad SDK install, or am I missing a step somewhere along the way?
 

Odofakyodo

Chieftain
Joined
Aug 3, 2021
Messages
10
Figured it out. The problem was that I did not have "Sid Meier's Civilization VI Development Assets" installed.
 
Top Bottom