1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. We have selected the winners of the Old World random draw and competition. For the winning entries, please check this thread.
    Dismiss Notice
  3. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

[GS] Error when trying to launch asset editor

Discussion in 'Civ6 - Technical Support' started by DeepSoul, Nov 26, 2020.

  1. DeepSoul

    DeepSoul Warlord

    Joined:
    Dec 30, 2011
    Messages:
    161
    When I try to launch asset editor it loads for a couple of second, I see some messages and one of two errors shows in read text. Either it's "Failed to start bug submission agent" or it's a very long message saying something about MEFCompositionException and AFT, and then it closes by itself. It's the same error reported here(except mine is in english and not french): https://forums.civfanatics.com/threads/asset-editor-error-mef-compositionexception.644704/

    My windows is in US English, so it's not about the language I think. I've also tried to move the SDK files to D:\SteamLibrary instead but that didn't help. What's causing this error and is there anything else I can do? I'm running Windows 10 and have installed Visual Studio.
     
    Knightfall likes this.
  2. Deliverator

    Deliverator Graphical Hackificator

    Joined:
    Feb 12, 2008
    Messages:
    4,738
    Location:
    London, UK
    You could try deleting the AssetEditor and AssetCloud directories from under C:\Users\<User>\AppData\Roaming then re-opening the Asset Editor.

    Clearing out the cache this way sometimes fixes issues with opening the Asset Editor.
     
  3. DeepSoul

    DeepSoul Warlord

    Joined:
    Dec 30, 2011
    Messages:
    161
    I have already solved this. The problem was that I didn't have the language in language settings set to US english. But thanks for replying.
     

Share This Page