FFH2 + BTS 3.19 crash

dfnehring

Chieftain
Joined
Mar 28, 2010
Messages
16
I am unable to get FFH to work with the BTS 3.19 patch. It works fine with BTS 3.17, but it crashes at launch with 3.19. My current install order is: CIV4 + latest patch + BTS + 3.17 patch + 3.19 patch + FFH2 (main install + 'o' patch + FFH2 media).

Could anybody explain to me how to make this work, please?
 

jprc

My dog is smarter than me
Joined
Sep 22, 2006
Messages
498
Location
Mozambique and far-far East
Did you install FFH2 in this order? :
(main install + 'o' patch + FFH2 media).

I never experienced the crash you are talking about in spite having installed/played Civ4+FFH2 into 6 different computers (with XP pro-sp3, W7-32 business, W7-64 ultimate)
I always installed the main file then the media THEN the latest patch. Not sure if it has an impact though...
Ah forgot: I have/had sometimes funny things happening with Vista (not yet with W7), with the "virtual store". Updating some files sometimes does not update the files in the folder you think it should, but update files in the "Virtual Store" as Vista thought it was a better compatible way...
(For information, Virtual Store is located into a hidden folder (Application data) inside the user's folder... )
 
Joined
Jan 7, 2009
Messages
1,922
It doesn't matter whether you install the media pack before or after the patch, although I recommend installing it before the patch as a matter of principle (because that way if updated media pack files were to one day be released as part of a patch, you would already be in the habit of installing in the correct order).

If you install FfH2 and Patch O, but you find that FfH2 will run under 3.17 and not under 3.19 then you've done something wrong. You may be using the wrong install files, or installing them in the wrong place. I suggest that you delete your "Fall from Heaven 2" folder, delete the installers and patchers that you have downloaded, and then make sure that Civ 4 is installed and patched correctly and working.

To do this, load Civ 4 and at the main menu select "ADVANCED" and then "ABOUT THIS BUILD". The line "Build Version" should read "3.1.9.0 (128100)". If yours does not match this, then you'll need to get Civ 4 + BtS installed and patched correctly before you proceed. I recommend installing Civ 4 + BtS + 3.19 patch. It should not be necessary to patch Civ 4 before installing BtS, and it should not be necessary to install patch 3.17 before installing patch 3.19.

Once Civ 4 + BtS v3.19 is working, you should download the FfH2 installer (called "2009_05_16_FallfromHeaven2041n.exe") and the FfH2 Patch O patcher (called "FfH2041o.exe") from the links in the first post of the FfH2 Bug Thread. (The media pack, if you want to install it, should also be downloaded and will be called "FfH2media.exe".) Install FfH2 to "[path]\Beyond the Sword\Mods" (where [path] is replaced by the path to your installation of Civ 4), then install the Media Pack if you care to (also to "[path]\Beyond the Sword\Mods"), then install Patch O (again, to "[path]\Beyond the Sword\Mods").

Once these steps have been completed successfully you should be able to play FfH2. I explain the details more fully in my thread How to Install FfH2. If you have any problems please consult that thread, and if your problem isn't solved there then let me know.
 

dfnehring

Chieftain
Joined
Mar 28, 2010
Messages
16
Thank you; it works now. The problem was a botched installation of several patches.
 
Top Bottom