Frozen Mouse


Feb 15, 2002
New to CIV III - got it about a week ago.

Currently running on 9.1, 733 G4. Have not had any problems except for these:

1. When I first loaded the game after installing, all the fonts were in dingbats form my font file. I tried reloading 6 times, but I finally had to go into my font folder and delete the font. Anyone else have this?

2. At random intervals, my mouse pointer will freeze on screen. All keyboard commands continue to work and the game continues as normal, with no mouse:mad: After quitting the game and reloading, the pointer functions again, until the next unexpected freeze. Any help here?

(My extentions are set to "Base" config)

:love: Excellent site, so helpful!

I have been having the same intermittent mouse freeze difficulties...running OS X. I'm not sure if this is a CIV 3 problem though. I think this is an Apple Optical Mouse problem. I noticed that unplugging and then replugging the mouse from the keyboard tends to un-freeze things, also reducing the tracking speed in your mouse control panel seemed to help prevent future freezes. If anybody else out there has any input about this (although it's not strictly a CIV question) I'd like to hear it.
ya my mouse froze on me earlier, just unplugged it, plugged it back in after command-Ping to finder and back, it worked fine.
Thanks for the added info...Unfortunately, the frozen mouse issue is still a hassle. To have to continously abort the game and reload whenever the mouse freezes is a constant headache, and is making me lose interest in CIV III (can that be??:confused: )

I have tried to unplug and replug the optical mouse, even to different USB ports, to no avail. I have decreased the mouse speed, no go either. What is command-Ping? That may work, but I am relatively new to Macs too (9 months) and do not know what that means.

I also play AOE2, CIV CTP, and Sid's AC games, and have never had this problem with the mouse before.

Is this the point where I buy a new mouse?:cry:

Thanks again....:D
sorry forgot you were usin 9.1
I'm runnin 10.1.3

command + P pauses civ 3 in OS X
your best bet is to prolly run it in X - after all now's a good time to upgrade, as almost every major app is ported now. You'll get crashes, but they're recoverable. - Civ 3 is FULL of bugs. Give the programmers some time and everythin will be worked out eventually.
Top Bottom