1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Game crashes when loading late games in BNW

Discussion in 'Civ5 - Technical Support' started by simcoast, Jan 20, 2014.

  1. simcoast

    simcoast Chieftain

    Joined:
    Jan 7, 2013
    Messages:
    22
    Hi,

    I've been having this issue for a while now with Civ 5: BNW and was wondering if anyone had any suggestions on how to get around it.

    Basically, I start new games with a few mods enabled and generally with a modded map that is larger than the 'Huge' size default map size.
    Everything runs smoothly until about 300-400+ turns into the game, where loading the saves starts to take upwards of 5 minutes.
    At this point, I assume there is quite a heavy load on the PC as I usually play with a large number of civs and there is a huge amount of information that needs to be processed.

    From this point onwards, either the load crashes the game or it works (generally with a 6:1 crash:load ratio). A lot of the time even when the save successfully loads farms disappear from the screen..
    When the load save crashes, it displays the loading screen for a few minutes, and then the background music stutters once, and then goes completely silent a moment later.
    At this point, the game has crashed and I have to alt-tab out to close the game..

    I've been thinking that this could be due to the large map size and the sheer amount of data the game has to load, but my PC specs are good and it should have no troubles in loading the game.
    I thought it might be the mods as well, but I would assume that if the mods were crashing, they wouldn't wait for so long into the game to start crashing.

    Does anyone have any suggestions that might help me out here?

    Cheers!
     
  2. simcoast

    simcoast Chieftain

    Joined:
    Jan 7, 2013
    Messages:
    22
    Here is my dxdiag anyway:

    ------------------
    System Information
    ------------------
    Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
    Language: Japanese (Regional Setting: Japanese)
    BIOS: BIOS Date: 03/09/12 10:55:17 Ver: 04.06.05
    Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (8 CPUs), ~3.5GHz
    Memory: 16384MB RAM
    Available OS Memory: 16348MB RAM
    Page File: 3300MB used, 29394MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     

Share This Page