Game not finding certain icons

Predator145

Warlord
Joined
May 22, 2020
Messages
215
My Steam version of the game simply can't find certain icons from downloaded unit graphics packs, forcing me to use another. Are there any requirements besides being 128x128 for a large icon and saved on a program such as GIMP?
 

Civinator

Blue Lion
Supporter
Joined
May 5, 2005
Messages
7,768
I´m very glad that I don´t have the Steam version of Civ 3 Complete with its unbelievable bugged labelstext file.

This said, the normal format for the icons for the civilopedia are 128x128 (large) and 32x32 (small), pcx, 256 colours, the last two colours in the palette when using PSP are magenta and 'poison'-green (see screenshot). The most common error is, that the image has 16Mio colours instead of 256 (in that case the icon in the game will be completly black).

You should also have a look into your pediaicons text file in the text folder, if the used icons have the proper spelling in that text file.
 

Attachments

  • Palette.jpg
    Palette.jpg
    54 KB · Views: 40

Predator145

Warlord
Joined
May 22, 2020
Messages
215
I´m very glad that I don´t have the Steam version of Civ 3 Complete with its unbelievable bugged labelstext file.

This said, the normal format for the icons for the civilopedia are 128x128 (large) and 32x32 (small), pcx, 256 colours, the last two colours in the palette when using PSP are magenta and 'poison'-green (see screenshot). The most common error is, that the image has 16Mio colours instead of 256 (in that case the icon in the game will be completly black).

You should also have a look into your pediaicons text file in the text folder, if the used icons have the proper spelling in that text file.

I fixed it to have 256 colors and got my self made icon to display. But now the white back ground is displayed in magenta...
 
Last edited:

Civinator

Blue Lion
Supporter
Joined
May 5, 2005
Messages
7,768
I fixed it to have 256 colors and got my self made icon to display. But now the white back ground is displayed in magenta...

You must find the proper places for both background colours in your graphics program. I use PSP, that´s why I showed you the palette settings for PSP. With other graphic programs it is working different - but there are tutorials for the most common graphic programms in the Civ 3 tutorial forum.
 
Top Bottom