1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

HELP! Snow Leopard/Quicktime problems

Discussion in 'Civ3 - Macintosh' started by jillrp, Jul 31, 2011.

  1. jillrp

    jillrp Chieftain

    Joined:
    Jul 31, 2011
    Messages:
    5
    MOVED HERE FROM GEN CIV 3 FORUM:

    Alright so I've searched high and low for answers to SEVERAL problems I've had since restoring my Mac from time machine - all the way back to fixing Terminal. Apple really needs to get their sh!t together because it has been a nightmare since the restore. ANYWAYS...I redownloaded my digital copy of Civ 3 Complete and it keeps saying every time I launch it that it "requires Quicktime 6.0 or later". I investigated that and, in the far-flung reaches of the outer galaxy, found an Apple support page detailing how to get Quicktime 7 back for older applications. I did that. I even went through and made sure the permissions were good on Quicktime. They are now. And yet I still get the same message every time. Following will be the crash report and I pray, fervently, that someone, somewhere can tell me what to do. Please.

    Process: Civilization 3 Complete NoCD X [733]
    Path: /Applications/Civ III Complete/Civilization 3 Complete.app/Contents/MacOS/Civilization 3 Complete NoCD X
    Identifier: com.aspyr.civ3conquests
    Version: 1.22 Rev. A (1.22 Rev. A)
    Code Type: X86 (Native)
    Parent Process: launchd [107]

    Date/Time: 2011-07-31 16:31:54.874 -0500
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 5388 sec
    Crashes Since Last Report: 7
    Per-App Interval Since Last Report: 253 sec
    Per-App Crashes Since Last Report: 7
    Anonymous UUID: FE41AEA8-ED53-441E-9777-9EFEBC71BC55

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x000000000000003f
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 ??? 0xa06000b4 vtable for __cxxabiv1::__class_type_info + 20

    REGARDING REVA PATCH: This patch put out by Aspyr is supposed to fix these issues I'm having but it is only for the box copy, not the digital download. Am I just SOL unless I get the box copy?
     
  2. AlanH

    AlanH Mac addict, php monkey Moderator Hall of Fame Staff Supporter GOTM Staff

    Joined:
    Jan 9, 2003
    Messages:
    28,855
    Gender:
    Male
    Location:
    England
    Your copy is patched up:
    Don't apply the box copy patch A. If you do you could actually turn your installed copy into a boxed copy, which then wants you to mount the DVD before you can play.

    I'm not sure what you are doing with Quicktime. I have Quicktime version 7.6.6. As far as I know it's the latest version for Snow Leopard. Civ3 Complete (box copy) runs fine here.

    I'm worried by your comments about problems with your TimeMachine restore. What else have you been having trouble with?

    Did you get your Civ3 from Aspyr/GameAgent? If so, have you tried contacting Aspyr Support?
     
  3. jillrp

    jillrp Chieftain

    Joined:
    Jul 31, 2011
    Messages:
    5
    The restore was just confusing with not a lot of support from Apple and so far the biggest problem I had was resetting the Terminal (which now runs fine). I haven't contacted support mainly because my past dealings with any kind of game support have been dreadful. But since I'm not getting any other answers I might just try for the heck of it. Thank you though!
     
  4. md2112

    md2112 Chieftain

    Joined:
    Jun 3, 2006
    Messages:
    8
    Location:
    Buffalo, NY
    Let's verify something - you should see a "Quicktime Player" application in your application folder - when you launch that, it should say that it's version 10.0 (128) (AKA Quicktime X). Then look for "Quicktime Player 7" application, mine is in the applications/utility folder. When you launch that it should say it's version 7.6.6 - that's the one you need. if you don't have that you can download it from the Apple support site. Go to Apple, click on support tab, search for Quicktime and you should find download of version 7.6.6 - At some point, Apple stopped installing version 7 with snow leopard and it became a separate download. I suspect if you were restoring, you must have reloaded a version of OS without it. I think it is option to load from DVD (maybe older DVD), but the download site is the best way to get it.
     
  5. jillrp

    jillrp Chieftain

    Joined:
    Jul 31, 2011
    Messages:
    5
    ^Yes, both are exactly like that. I got quicktime 7 from the install dvd and updated it to 7.6.6. I even have it in both Utilities and Applications. I did EVERYTHING I was told to do online and still nothing.
     

Share This Page