How to add new assets, step by step

Well that's an unexpected side effect.
Does Asset Explorer work? ( Is it documented anywhere that Asset Studio doesn't work with 2021 or is it just something that people notice?

There are quite a lot of open issues describing the same error that I'm getting. I guess the creator didn't want to fix or maintain it anymore for whatever reason. I'll take a look at Asset Explorer.
Is it because of the latest OW patch? Or did they move to another Unity version before then? I ask because last time i tried AssetStudio export to .fbx, it was successful. As soon as ZBrush has something completed, i will check myself.
It's a change on our end - we upgraded to 2021.3 two patches ago.
Ah, yeah, i understand. And now i know why last time the export was successful, because i have a second copy of Old World on Epic Games, where i was not online for several months now. So my Epic copy is not updated, but my Steam copy is, and i am getting errors also with AssetStudio for the Steam copy. I hope Deliverator have success with Asset Explorer.
Good news! This forked version of Asset Studio can unbundle the latest 2021.3.24 Old World assets and is apparently still in active development for now. There is no latest release on Github so I had to compile myself in VS2022 but we can address that.


I kind of knew that you would find a way :D
This are really good news.
OK. You can grab the latest build of this working version of Asset Studio from here for now:

I as a VS noob managed to build that forked AssetStudio version inside VS 2022, so that it builds out a .exe file (finally, after multiple problems), but i am getting errors in VS, plus the .exe will not do anything :D

Those are the two errors, if i build AssetStudioGUI:

1. ... \Desktop\AssetStudio-AssetStudioMod\AssetStudioFBXNative\asfbx_anim_context.h(3,10): fatal error C1083: Datei (Include) kann nicht geöffnet werden: "fbxsdk.h": No such file or directory

'Datei (Include) kann nicht geöffnet werden' is german and means: data/file cannot be opened

2. ... Desktop\AssetStudio-AssetStudioMod\AssetStudioGUI\AssetStudioGUI.csproj(79,9): error MSB3030: Datei "C:\Users\ryuto\Desktop\AssetStudio-AssetStudioMod\AssetStudioFBXNative\bin\Win32\Release\AssetStudioFBXNative.dll" konnte nicht kopiert werden, da die Datei nicht gefunden wurde.

'konnte nicht kopiert werden, da die Datei nicht gefunden wurde.' is german and means: could not be copied, because the file could not be found

Hehe, it seems that me and everything related to coding is still not something which works together nicely :D

Anyways, how was you able to build this AssetStudio version? Are there some steps i have to do first, before i can build the project in VS?
@Deliverator Thanks, it was not easy for me, but i have a working AssetStudio now, via the Github method. =)
@Deliverator note that as of the recent Test build, you can override UI xml files directly in your mod folder. No need for asset bundling them. Also, the UI xml files have been added to the Reference folder.
@Shirotora Kenshin OK I'm closing in on completing the description of how to get 3D unit models back and forth between Old World Unity and Blender. There are still some elements of this to describe but sharing what I have in case it is useful.


  • Old World Graphics Modding Guide v0.3.pdf
    17.8 MB · Views: 24
@Deliverator Cool, i will look into it as soon as possible. Already thank you for all your efforts so far!

Edit: I looked into it, this will already be very helpful. Also good to see that you will address custom 3D static improvements at some point, i guess new Wonders count as improvements.
In the next couple of days i can try to follow your guide step-by-step, starting with adding a 2D image of a new Leader i already made. Thank you again!
Last edited:
any news about 3d assets modification?

I think Deliverator is just busy with reallife, and i am too by the way.
We all need to have patience. :)
Top Bottom