How To: Make Leaderheads! Ekmek's Guide


on steam: ekmek_e
Aug 7, 2002
San Diego, California

attached is my guide that will take you from Blender through Nifskope and has Wolfshanze's XML guide. Please give it a shot and tell me if something is vague or unclear. Start with these downloads:

Spoiler :

To get blender to work with Civ files you need to download these programs and install in THIS SEQUENCE. Downloads for 32-bit windows and tested on Vista.
1. PYTHON 2.6.2 (32 BIT WINDOWS)
2. BLENDER 2.49a ( FOR 32-BIT WIN)
3. PyFFI-py2.6-2.0.1-windows
4. Blender 2.4.10 NIFSCRIPTS

6. [OPTIONAL] my leaderhead parts might be useful too

Click HERE to Download my Guide

For questions please post your blend and if successful latest nif. If for some reason I don't get back to you I'm sure you can contact these other fine LH makers:

The Capo
cfkane (but I think he figured it on his own)
Methyl Orange
coffee junkie

Huyana Capac357
Gizmo Uberforce
Very cool ! Ekmek, if you need accessories like crown or something, I will gladly do half a dozen for you to get paid back. I cannot do entire leaderheads because it's unmanageable om my comp but parts are ok if they are already separated. Blender/Nifskope Combo is so awesome, man.

hmmm, I think there's something I can tell you :

In UAV Face select you can shift click to select face according to the texture. When done, press delete key and choose remove faces (it will preserve vertices that are needed for unselected faces). I call this way BFD for blender face deletion process.
Roland's tut i sbest for nifskope:

but what you need to do is have it so when you click on a nif it opens directly to nifskope (this should be standard when you install nifskope)

so click on the blender export nif i.e. lincoln_x.nif
then click on the original that you copied to your new lh folder - lincoln.nif
now you have two nifskopes open
click on the body in the original nif and see what ninode in the tree on the left the trishape is in
now click on your new lincoln and right-click copybranch on your new trishape
go to the original lincoln and right click on the nidode and paste the branch
right-click on the original bosy and right-click remove the branch
if you added new stuff like a hat just keep copying the branch and pasting it in the original ninode
that should do it!

thanks. I'll check out your method too!
I must be stupid, didn't understand anything except for how to download... :blush:

i'm stuck on page 4 :p

Spoiler :

As you see, i don't have the other 3 square thing's like you have in picture 1 and when i click the 1 square i have, i don't see the "NetImmerse/GameBryo" option. Maybe i didn't install things right?
did you install the nifscripts? I cant help at the moment but this link might help out:

EDIT: the nifscripts is an exe that you have to run did you do that? are you using blender 2.43 (what the guide is based on)or 2.45 (newer version that i havent used)
hiya. your tutorial came at the right time. I'm using it right now. I'm an autoCAD guy and am new to gaming 3D.
page 4 doesnot have enough detail...until i update to 1.1 follow this

-Install blender first
-install the nifscripts into the same directory
when blender starts you need to
-Run the import and export script at least once to register the scripts in Blender's configuration system:
File -> Import -> NIF -> Cancel.
File -> Export -> NIF -> Cancel.

Thanks to TheLastone36
Sounds interesting Ek, I'll go over it later and scan for errors. ;) (;))

Bah I can't hold it in, great job. :thumbsup:

Very neat and pristine, I'll try to add more if I can.
Hey Ekmek. I tried to fix that Istvan LH again. I had a lokk at your guide. What should I say? My blender is looking different (editing the nif scripts part) and after importing the LH I can't do any changes to the nif. I can't switch to edit mode... I tried it with original files from civ4, too, no chance. I use Blender 2.45, don't know if this could be the problem... Otherwise it seems to me that I am too stupid for that... I think I give it up...

EDIT: I've just recognized that TheLastOne36 has the same difference in the nif script preferences...
Spoiler :
for me Blender stops on page 4. Is this the end of the line ? Or should I have NifSkope installed before Blender looks the same as Blender in the tutorial ?
Top Bottom