In game HOF crashes

shmily_dana

Warlord
Joined
Mar 7, 2006
Messages
284
My question does NOT refer to the mod.

Since the last BTS patch, my in-game HOF crashes. It does not always sort correctly. My guess is that one of the archive game files is corrupt. Or perhaps it is having trouble with the games pre-patch. I'll probably just purge everything, unless I hear a better idea.

thanks
 

ori

Repair Guy
Retired Moderator
Joined
Dec 17, 2005
Messages
16,561
Location
Baden-Württemberg, Germany
please open your civilizationIV.ini and set all items with log in their name from 0 to 1 so that the bottom of that file looks as below. start the game and recreate the crash - then post your logs as a zip file attachment.

the .ini is in my games\beyond the sword
the logs are in my games\beyond the sword\logs


Code:
; Enable the logging system
LoggingEnabled = 1

; Enable synchronization logging
SynchLog = 1

; Overwrite old network and message logs
OverwriteLogs = 1

; Enable rand event logging
RandLog = 1

; Enable message logging
MessageLog = 1

; Break on memory allocation order #
BreakOnAlloc = -1
 

shmily_dana

Warlord
Joined
Mar 7, 2006
Messages
284
After doing a few sorts on my HOF, I get: "Pure Virtual Function Call"

see attached logs

thanks
 

Attachments

  • Logs.zip
    8.5 KB · Views: 38
  • Logs.rar
    7.9 KB · Views: 40

ori

Repair Guy
Retired Moderator
Joined
Dec 17, 2005
Messages
16,561
Location
Baden-Württemberg, Germany
:hmm:
unfortunately the logs do not contain anything that sheds light on this - so I guess it is indeed best to either delete all the replay files or just rename the replays folder and let the game start a new HOF - if that works your could move some of the old files back...
 
Top Bottom