1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

ingame videos stutter and freeze (solution)

Discussion in 'Civ4 - Technical Support' started by Jean Elcard, May 18, 2008.

  1. Jean Elcard

    Jean Elcard The Flavournator

    Joined:
    Feb 26, 2006
    Messages:
    1,008
    Location:
    Leipzig, Germany
    After upgrading from a single-core to a dual-core CPU (AMD Athlon 64 X2 4800+) and a new mainboard I got a very annoying problem with Civilization 4 under Windows XP. All the ingame videos (intros, wonder movies etc.) started to stutter and eventually froze after a few seconds. The sound startet looping faster and faster until freezing too. Sometimes the freeze stopped after a while and the stuttering and looping began again. Sometimes I even had to reset my computer to get out of a very prolonged freeze.

    My first solution was to disable the movies entirely or to click fast enough to skip the movie before it gets the chance to freeze.

    After trying a lot of things with CPU, nvidia video and mainboard drivers and binkw32.dll files, I came finally up with a better solution:

    1. Install the "AMD Dual-Core Optimizer"
    2. Set "SyncInput" in your CivilizationIV.ini from "0" to "1".
    3. Enjoy smooth playing ingame-videos. :)

    I don't know, if the first step is really necessary, but to install the AMD Dual-Core Optimizer under XP is recommended anyway.

    I hope I could help at least someone with this.
     
  2. Random Fires

    Random Fires Chieftain

    Joined:
    Jun 24, 2008
    Messages:
    94
    Location:
    Canada
    Anytime I set this value to 1, and launch the game, the same stuttering occurs. I recheck the .ini file and it resets back to "0" Any ideas? All cpu games I've bought never fully work, the prime reason I gave up on cpu gaming. I just got Civ4 as a temporary game to play waiting for revolution, now I'd love it if I could get this thing to work fully(now I'm addicted). It's cheap, but it'd be great if it work fully.
     
  3. Tielby

    Tielby Prince

    Joined:
    Sep 23, 2007
    Messages:
    342
    Location:
    The sacred and free citadel of mind
    Strangely, I cannot find any file by that name.

    As was mentioned by others in other threads, my vanilla Civ is working fine. Why would the FfH movies react differently?
     
  4. Jean Elcard

    Jean Elcard The Flavournator

    Joined:
    Feb 26, 2006
    Messages:
    1,008
    Location:
    Leipzig, Germany
    Sorry, the file's correct name is CivilizationIV.ini. It's not in your Civilization 4 directory. You'll find it in the directory "My Documents\My Games\Beyond the Sword\"

    No idea. To be honest, I can't remember, if the Vanilla civ movies were working for me. I was playing exclusively FfH when I had this problem.
     

Share This Page